Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34768 - [systemd,udev] After upgrade to systemd 200-201 removable USB drives cannot be mounted

Attached to Project: Arch Linux
Opened by Radu Potop (wooptoo) - Saturday, 13 April 2013, 21:15 GMT
Last edited by Dave Reisner (falconindy) - Monday, 15 April 2013, 20:28 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

I noticed this after the upgrade to systemd 200-201. When I plug in a removable USB drive (mass-storage drive) I get these errors in journald and the drive fails to mount. I tried with multiple devices, same result.


Apr 14 00:02:00 blue kernel: scsi 9:0:0:0: Direct-Access pqi IntelligentStick 0.00 PQ: 0 ANSI: 2
Apr 14 00:02:01 blue kernel: sd 9:0:0:0: [sdc] 3948544 512-byte logical blocks: (2.02 GB/1.88 GiB)
Apr 14 00:02:01 blue kernel: sd 9:0:0:0: [sdc] Write Protect is off
Apr 14 00:02:01 blue kernel: sd 9:0:0:0: [sdc] Mode Sense: 00 00 00 00
Apr 14 00:02:01 blue kernel: sd 9:0:0:0: [sdc] Asking for cache data failed
Apr 14 00:02:01 blue kernel: sd 9:0:0:0: [sdc] Assuming drive cache: write through
Apr 14 00:02:03 blue kernel: sd 9:0:0:0: [sdc] Asking for cache data failed
Apr 14 00:02:03 blue kernel: sd 9:0:0:0: [sdc] Assuming drive cache: write through
Apr 14 00:02:04 blue kernel: sdc: sdc1
Apr 14 00:02:05 blue kernel: sd 9:0:0:0: [sdc] Asking for cache data failed
Apr 14 00:02:05 blue kernel: sd 9:0:0:0: [sdc] Assuming drive cache: write through
Apr 14 00:02:05 blue kernel: sd 9:0:0:0: [sdc] Attached SCSI removable disk
Apr 14 00:02:34 blue systemd-udevd[118]: worker [26249] /devices/pci0000:00/0000:00:1a.7/usb5/5-1/5-1:1.0/host9/target9:0:0/9:0:0:0/block/sdc timeout;
Apr 14 00:02:34 blue systemd-udevd[118]: seq 1747 '/devices/pci0000:00/0000:00:1a.7/usb5/5-1/5-1:1.0/host9/target9:0:0/9:0:0:0/block/sdc' killed
Apr 14 00:02:34 blue systemd-udevd[118]: worker [26249] terminated by signal 9 (Killed)


I use:

systemd 201
kernel 3.8.6 x86_64
This task depends upon

Closed by  Dave Reisner (falconindy)
Monday, 15 April 2013, 20:28 GMT
Reason for closing:  Not a bug
Comment by Dave Reisner (falconindy) - Sunday, 14 April 2013, 17:48 GMT
What rules do you have in /etc/udev/rules.d?
Comment by Radu Potop (wooptoo) - Sunday, 14 April 2013, 18:13 GMT
These two:

::::::::::::::
60-scheduler.rules
::::::::::::::
# set noop scheduler for non-rotating disks
ACTION=="add|change", KERNEL=="sd[a-z]", ATTR{queue/rotational}=="0", ATTR{queue/scheduler}="noop"

# set cfq scheduler for rotating disks
ACTION=="add|change", KERNEL=="sd[a-z]", ATTR{queue/rotational}=="1", ATTR{queue/scheduler}="cfq"

::::::::::::::
80-net-name-slot.rules
::::::::::::::
# This file masks persistent renaming rules for network devices. If you
# delete this file, /usr/lib/udev/rules.d/80-net-name-slot.rules may
# rename network devices according to ID_NET_NAME_{ONBOARD,SLOT,PATH}
# properties of your network devices, with priority in that order. See
# the output of 'udevadm test-builtin net_id /sys/class/net/$interface'
# for details on what that new name might be.
#
# http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames
Comment by Radu Potop (wooptoo) - Monday, 15 April 2013, 20:26 GMT
Fixed in kernel 3.8.7.

Loading...