Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34747 - [netctl] Systemd messages about login prompt

Attached to Project: Arch Linux
Opened by Ypnose (Ypnose) - Friday, 12 April 2013, 11:15 GMT
Last edited by Jouke Witteveen (jouke) - Saturday, 13 April 2013, 11:46 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Jouke Witteveen (jouke)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:

After my system boots, systemd prints messages about netctl connection, above login prompt.
Using multi-user.target.
Picture: http://linuxien.legtux.org/uploads/images/Temp/133230.jpg
Opened a thread: https://bbs.archlinux.org/viewtopic.php?pid=1257873

Additional info:
* package version(s)
netctl 0.8-1
systemd 200-1
* config and/or log files etc.
Included my profile

Steps to reproduce:
Enable wifi profile with multi-user.target and then reboot.

Fix:
Modify the service file from "After=sys-subsystem-net-devices-wlp0s19f2u2.device" to "After=sys-subsystem-net-devices-wlp0s19f2u2.device multi-user.target"

Could you add an option to netctl which do the trick (as @ with netcfg)?
   Madbox (0.3 KiB)
This task depends upon

Closed by  Jouke Witteveen (jouke)
Saturday, 13 April 2013, 11:46 GMT
Reason for closing:  Not a bug
Comment by Dave Reisner (falconindy) - Friday, 12 April 2013, 12:37 GMT
The proper "fix" here is to ignore the cosmetic glitch. Adding busted ordering to netctl's units is nothing short of a filthy hack.
Comment by Ypnose (Ypnose) - Friday, 12 April 2013, 12:59 GMT
I'm aware it's a filthy hack, but this is the only thing I found to resolve the issue. I'm not saying you should add "multi-user.target" on every profile, I just said you could add an option to fix what I showed.
Actually I don't know how. Netcfg provided a proper way to start a profile in the background.
And no, this is not only a cosmetic glitch since it breaks line and avoids successful login.
Comment by Dave Reisner (falconindy) - Friday, 12 April 2013, 13:07 GMT
No, it doesn't break your login. You're quite mistaken on this point.
Comment by Ypnose (Ypnose) - Friday, 12 April 2013, 14:49 GMT
Are you going to help me, even if it's "cosmetic" and boring?
Comment by Dave Reisner (falconindy) - Friday, 12 April 2013, 14:55 GMT
Me? No, I'm not. There's already been more than sufficient whining about this upstream and here.

https://bugs.freedesktop.org/show_bug.cgi?id=54247
Comment by Jouke Witteveen (jouke) - Saturday, 13 April 2013, 11:46 GMT
This is in fact something to be proud of. It is the result of starting things as early as possible and in parallel. I don't think this is a bug but for sure it is not a bug in netctl (Dave is right, as he usually is).

There are at least 3 fixes you can apply:
1) add 'quiet' to your kernel command line
2) have your system switch to tty2 on boot so that messages on tty1 don't interfere with anything
3) add an ordering statement to /etc/systemd/system/getty.target.wants/getty\@tty1.service, namely 'After=network.target'

Loading...