Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34679 - [grml-zsh-config] Oh-my-zsh no longer working

Attached to Project: Arch Linux
Opened by Alphazo (alphazo) - Monday, 08 April 2013, 10:10 GMT
Last edited by Evangelos Foutras (foutrelis) - Monday, 08 April 2013, 16:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

When upgrading to 0.8.1-1 I can no longer get the prompt defined in my oh-my-zsh profile. When downgrading to 0.7.4 it works.


Steps to reproduce:
1) # git clone git://github.com/robbyrussell/oh-my-zsh.git ~/.oh-my-zsh
2) Download the attached two config files and save them under ~
3) Open a new terminal, theme is Kolo so the prompt should look like "~%" and not "user@machine %"

When using grml 0.7.4 I get the correct "~%" prompt and I get "user@machine %" when upgrading to 0.8.1.




This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Monday, 08 April 2013, 16:51 GMT
Reason for closing:  Not a bug
Comment by Alphazo (alphazo) - Monday, 08 April 2013, 10:31 GMT
Found out that grml 0.8 implements its own custom prompt therefore in order to use oh-my-zsh prompt theme you need to add

prompt off

in ~/.zshrc

More info here: http://bewatermyfriend.org/p/2013/003/

Loading...