Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34643 - [wireshark-cli] from Extra depends on "portaudio" from Community.

Attached to Project: Arch Linux
Opened by adrian (ado60) - Saturday, 06 April 2013, 18:08 GMT
Last edited by Guillaume ALAUX (galaux) - Sunday, 07 April 2013, 20:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Guillaume ALAUX (galaux)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Package "wireshark-cli" is in the Extra repository but depends on package "portaudio", which is in Community.
This is for both x86_64 and i686.

Additional info:
* package version(s): wireshark-cli 1.8.6-1 ; portaudio 19_20111121-1 ;
* my repositories in pacman.conf: core, extra, multilib
* pacman v4.1.0 - libalpm v8.0.0 log (but it was doing the same thing before pacman4):
# pacman -S wireshark-cli
resolving dependencies...
warning: cannot resolve "portaudio", a dependency of "wireshark-cli"
:: The following package cannot be upgraded due to unresolvable dependencies:
wireshark-cli

:: Do you want to skip the above package for this upgrade? [y/N] N
error: failed to prepare transaction (could not satisfy dependencies)
:: wireshark-cli: requires portaudio

Steps to reproduce:
Remove the Community repository from pacman.conf. (Remove the "portaudio" package if you have it installed).
# packman -S wireshark-cli
This task depends upon

Closed by  Guillaume ALAUX (galaux)
Sunday, 07 April 2013, 20:51 GMT
Reason for closing:  Fixed
Additional comments about closing:  Wireshark rebuilt without portaudio support in 1.8.6-2
Comment by Jan Alexander Steffens (heftig) - Sunday, 07 April 2013, 18:56 GMT
Either upgrade portaudio to [extra] or drop the dep from wireshark. I'd prefer the latter, since portaudio also pulls in jack. All it adds is listening to RTP streams.

Loading...