Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34578 - [qemu] Live migration currently broken

Attached to Project: Arch Linux
Opened by Kevin Shanahan (kmshanah) - Tuesday, 02 April 2013, 23:02 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Thursday, 04 April 2013, 10:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Live migration is currently broken for me (using libvirt).

Additional info:

* qemu 1.4.0-2
* libvirt 1.0.4-1

Steps to reproduce:

# virsh migrate --live --verbose arch1 qemu+ssh://10.48.50.241/system
error: operation failed: migration job: unexpectedly failed

From /var/log/libvirt/qemu/arch1.log:
qemu: warning: error while loading state section id 2
load of migration failed

The patch 0002-migration-buffer-retry-on-eagain.patch from http://ppa.launchpad.net/serge-hallyn/virt/ubuntu/pool/main/q/qemu/qemu_1.4.0+dfsg-1expubuntu5~ppa1.debian.tar.gz fixes the problem for me (see this launchpad bug: https://bugs.launchpad.net/bugs/1157626)
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Thursday, 04 April 2013, 10:22 GMT
Reason for closing:  Not a bug
Comment by Kevin Shanahan (kmshanah) - Wednesday, 03 April 2013, 21:34 GMT
Sorry, this patch wasn't the fix - the problem was actually fixed by libvirt 1.0.4 and not the patch I tested. Sorry for the wrong report, will close it now.

Loading...