Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34576 - LibreOffice 4 crashes at startup

Attached to Project: Arch Linux
Opened by Timo Ollech (pcab50) - Tuesday, 02 April 2013, 19:29 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 06 April 2013, 14:36 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

After upgrading libreoffice from 4.0.1-2 to 4.0.1-5 it crashes at startup saying

terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'

Output of libreoffice --backtrace attached.


Steps to reproduce:

Upgrade LibreOffice from 4.0.1-2 to 4.0.1-5
Start program (from terminal to see error message)


See also https://bbs.archlinux.org/viewtopic.php?pid=1253202
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 06 April 2013, 14:36 GMT
Reason for closing:  Fixed
Comment by Alexandre de Verteuil (a_neutrino) - Wednesday, 03 April 2013, 00:45 GMT
According to this related post (marked as [solved]), removing libreoffice-extension-numbertext should fix your problem. I had LO crash with the same error message when starting to type a formula in Calc. Removing that extension fixed it. Didn't need to remove .config files.

https://bbs.archlinux.org/viewtopic.php?id=160428

Sincerely,

Alexandre de Verteuil
Comment by Timo Ollech (pcab50) - Wednesday, 03 April 2013, 10:20 GMT
I don't have this package installed, so it can't be the reason.
Comment by Alexandre de Verteuil (a_neutrino) - Wednesday, 03 April 2013, 11:14 GMT
Well, in a more general way, the solution was to remove any extension that was outdated, such as those installed from AUR or locally. Compare
pacman -Qs libreoffice-extension
with packages from the official repositories. Then, trial and error. It just happened that for three of us, numbertext was the one.
Comment by Timo Ollech (pcab50) - Wednesday, 03 April 2013, 11:31 GMT
all of my libreoffice-extension packages are from extra, so once again: it's not about outdated or buggy extensions...
Comment by George Savvidis (helix) - Thursday, 04 April 2013, 03:01 GMT
He's absolutely right, I have no libreoffice extensions installed at all ("pacman -Qs libreoffice-extension" returns nothing) and I have exactly the same problem.
Comment by Andreas Radke (AndyRTR) - Friday, 05 April 2013, 04:41 GMT
Please check new LibO 4.0.2-1.
Comment by George Savvidis (helix) - Friday, 05 April 2013, 05:29 GMT
I did yesterday, and doesn't crash on startup now.
Comment by Timo Ollech (pcab50) - Saturday, 06 April 2013, 14:13 GMT
fixed with 4.0.2

Loading...