Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34565 - [stunnel] Problem with stunnel -4.56-1 in Emacs View Mail, resolved after downgrading to 4.54-1

Attached to Project: Community Packages
Opened by Peter Mous (thinspine) - Tuesday, 02 April 2013, 03:33 GMT
Last edited by Lukas Fleischer (lfleischer) - Tuesday, 18 June 2013, 09:23 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Lukas Fleischer (lfleischer)
Architecture i686
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

After a full update on March 31 (sudo pacman -Suy), I got the following error message in View Mail (under Emacs 24.3.1) when downloading from a POP server:

vm-pop-check-connection: POP connection not open: POP over SSL

The problem disappeared after downgrading the package stunnel from stunnel-4.56-1 to stunnel 4.54-1

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Lukas Fleischer (lfleischer)
Tuesday, 18 June 2013, 09:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 4.56-3.
Comment by Jelle van der Waa (jelly) - Friday, 05 April 2013, 17:58 GMT

$ systemctl start stunnel.service
Job for stunnel.service failed. See 'systemctl status stunnel.service' and 'journalctl -xn' for details.

$ stunnel
Clients allowed=500
stunnel 4.56 on x86_64-unknown-linux-gnu platform
Compiled/running with OpenSSL 1.0.1e 11 Feb 2013
Threading:PTHREAD Sockets:POLL,IPv6 SSL:ENGINE,OCSP,FIPS
Reading configuration from file /etc/stunnel/stunnel.conf
FIPS_mode_set: F06D065: error:0F06D065:common libcrypto routines:FIPS_mode_set:fips mode not supported
Line 24: "[proxy]": Failed to initialize SSL
str_stats: 4 block(s), 64 data byte(s), 232 control byte(s)
Comment by Jonathan Liu (net147) - Wednesday, 10 April 2013, 05:18 GMT
Need to add "fips = no" to global options in stunnel.conf.

Loading...