Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#34543 - [gnome] System hangs when starting GDM

Attached to Project: Arch Linux
Opened by Yangtse Su (yangtsesu) - Monday, 01 April 2013, 08:38 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 23 July 2013, 08:24 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 11
Private No


After upgrade to [gnome-unstable],System hangs when starting gdm.service.
No log found.

1. "#systemctl start gdm.service" could start gdm ,after run startx to exec awesome and quit.
2. slim work well with gnome-shell.
3. journalctl is empty. arguements too long.
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 23 July 2013, 08:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed some mesa versions ago.
Comment by Yangtse Su (yangtsesu) - Tuesday, 02 April 2013, 00:44 GMT Comment by Yangtse Su (yangtsesu) - Thursday, 11 April 2013, 04:26 GMT
Now,gnome 3.8 is in testing,so please remove [gnome-unstable].
Thank you.
Comment by Matthew Wardrop (mister.wardrop) - Friday, 12 April 2013, 00:04 GMT
As indicated in this ( post on the forum, this seems to be related to upstream issues with the Intel driver (
Comment by Yangtse Su (yangtsesu) - Friday, 12 April 2013, 01:11 GMT
Thank you.I think you are right.
sddm freeze too.
Comment by Yangtse Su (yangtsesu) - Saturday, 13 April 2013, 04:46 GMT Comment by Olivier Mehani (shtrom) - Tuesday, 23 April 2013, 01:28 GMT
Same problem on a Dell e6320 (linux-3.8.8-1, xorg-server-1.14.(0-2|1-1), xf86-video-intel-2.21.6-1 and gdm-

Using SLiM fixes the problem.
Comment by Dennis Barzakovsky (iddqd) - Tuesday, 23 April 2013, 13:09 GMT
the same problem here and gnome 3.8 is stable now, so I got it after pacman -Syu
Xfce4 session starts with lightdm only
Comment by lainme (lainme) - Thursday, 02 May 2013, 07:27 GMT
It's already marked resolved upstream

Update: looks like I misunderstood the status.