Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34542 - [makepkg] getting 'is not available for the '@CARCH@' architecture' message

Attached to Project: Arch Linux
Opened by Frederic Bezies (fredbezies) - Monday, 01 April 2013, 08:34 GMT
Last edited by Allan McRae (Allan) - Monday, 01 April 2013, 09:10 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Hello.

Since I upgraded to pacman 4.1.0, every single time I tried to build a package, I'm getting this kind of message, for example while trying to build pacman from source code :

$ makepkg -s
==> ERROR: pacman is not available for the '@CARCH@' architecture.
Note that many packages may need a line added to their PKGBUILD
such as arch=('@CARCH@').

Of course, I've made a clean update of pacman, and to be sure I have a good makepkg.conf, I remove the old one and use makepkg.conf.pacnew I get with sudo pacman -S pacman.

Additional info:
pacman 4.1.0-1

Steps to reproduce:

Just install pacman 4.1.0 and try to build a package from source.
This task depends upon

Closed by  Allan McRae (Allan)
Monday, 01 April 2013, 09:10 GMT
Reason for closing:  Not a bug
Comment by Allan McRae (Allan) - Monday, 01 April 2013, 08:51 GMT
What architecture are you using? Post your makepkg.conf.
Comment by Evangelos Foutras (foutrelis) - Monday, 01 April 2013, 08:52 GMT
makepkg works fine here and '@CARCH@' as a string is nowhere to be found inside the pacman package.

It'd be interesting to find out what's happening on your system; I can't think of any probable cause for that error.

I guess you could check the /etc/makepkg.conf and $HOME/.makepkg.conf files for any instances of '@CARCH@'.
Comment by Frederic Bezies (fredbezies) - Monday, 01 April 2013, 08:58 GMT
@allan : x86_64

@foutrelis : I do not have .makepkg.conf in my home directory.

Only /etc/makepkg.conf from pacman package.

The only modification I made is using MAKEFLAGS="-j4". Besides this, it is the same file as the one in pacman package.
Comment by Frederic Bezies (fredbezies) - Monday, 01 April 2013, 09:05 GMT
Looks like upgrade went wrong. /etc/makepkg.conf was badly upgraded :(

CARCH and CHOST were badly written :(
Comment by Allan McRae (Allan) - Monday, 01 April 2013, 09:05 GMT
So... where did you get this makepkg.conf? ABS?

Edit: makepkg.conf not pacman.conf
Comment by Frederic Bezies (fredbezies) - Monday, 01 April 2013, 09:07 GMT
I don't know. I was upgrading the package the right way, using sudo pacman -S pacman... Weird, really weird :(
Comment by Allan McRae (Allan) - Monday, 01 April 2013, 09:09 GMT
The only way to get that makepkg.conf is taking it from ABS or SVN. The version distributed in the pacman-4.1.0-1-x86_64 package is correct.

Loading...