Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34498 - [libreoffice-calc]

Attached to Project: Arch Linux
Opened by mattia (nTia89) - Wednesday, 27 March 2013, 18:36 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 01 June 2013, 09:58 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
calc crash if I try to expand a cell that contains "Err:520" e.g. F15 cell in my worksheet (attached)

if I try to it in Windows XP with libreoffice 4.0.1 (32bit) I don't have any cells with "Err:520"

run it in a terminal i get:

terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'

Additional info:
* libreoffice-x86_64-4.0.1-5


Steps to reproduce:
open the file attached and try to expand the F15 cell
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 01 June 2013, 09:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  initial bug is solved. every other bug should be reported in a new issue.
Comment by mattia (nTia89) - Wednesday, 27 March 2013, 18:37 GMT
please mod edit the title as I forget to fill it....
Comment by Jorge Barroso (jorge_barroso) - Wednesday, 27 March 2013, 21:20 GMT
Hi mattia, have you got the full libreoffice suite installed? If not, could you install it and check again?
Comment by mattia (nTia89) - Wednesday, 27 March 2013, 21:29 GMT
except base, I have the full suite+2 extensions+2 language-pack:

extra/libreoffice-calc 4.0.1-5 (libreoffice) [installed]
extra/libreoffice-common 4.0.1-5 (libreoffice) [installed]
extra/libreoffice-draw 4.0.1-5 (libreoffice) [installed]
extra/libreoffice-en-GB 4.0.1-1 [installed]
extra/libreoffice-extension-nlpsolver 4.0.1-5 (libreoffice-extensions) [installed]
extra/libreoffice-extension-presentation-minimizer 4.0.1-5 (libreoffice-extensions) [installed]
extra/libreoffice-gnome 4.0.1-5 (libreoffice) [installed]
extra/libreoffice-impress 4.0.1-5 (libreoffice) [installed]
extra/libreoffice-it 4.0.1-1 [installed]
extra/libreoffice-math 4.0.1-5 (libreoffice) [installed]
extra/libreoffice-writer 4.0.1-5 (libreoffice) [installed]
Comment by Jorge Barroso (jorge_barroso) - Wednesday, 27 March 2013, 21:48 GMT
mmh... a weeks ago I reported a bugrelated to an already existent one and the result was that looks like every libreoffice interfaces depend on almost all of the other ones, so... could you try to install base (without calc started) and try to reprouce the bug? if your problems still unsolved, then, we could be on a real, independent bug :)
Comment by mattia (nTia89) - Wednesday, 27 March 2013, 21:53 GMT
still happens...
Comment by Andreas Radke (AndyRTR) - Wednesday, 27 March 2013, 22:34 GMT
Proove it to be a packaging bug or report it upstream. So far I've never seen this before in Arch. Make sure all optional dependencies are installed.

Google also finds some results for "Err:520"...
Comment by mattia (nTia89) - Friday, 29 March 2013, 10:26 GMT
I've installed all optional dependencies but with no luck.

I open an upstream bug ( https://bugs.freedesktop.org/show_bug.cgi?id=62900 ), but since this problem doesn't occur in Win XP SP3 (almost vanilla), I think this is our problem.
Comment by mattia (nTia89) - Friday, 29 March 2013, 12:26 GMT
I found that if I try to expand any cell calc crashes with the same error!
Comment by Jorge Barroso (jorge_barroso) - Friday, 29 March 2013, 12:44 GMT
mmm... could be but think that Win and linux are different... I tried to expand the cell and calc didn't crash.
Comment by Andreas Radke (AndyRTR) - Friday, 29 March 2013, 13:28 GMT
Please check if you are running into this one: https://bugs.freedesktop.org/show_bug.cgi?id=60215 or if it is something different.
Comment by mattia (nTia89) - Friday, 29 March 2013, 13:36 GMT
libreoffice is becoming a fiend:

1. open calc
2. start to write a formula (namely type '=') in any cell and calc crashes
Comment by M. P. (mpausch) - Tuesday, 02 April 2013, 19:23 GMT
mattia: had the same problem.
after uninstalling all libreoffice-extensions Calc doesn't crash any more on my box.

In output of "pacman -Q" I saw that some extensions are not version 4.0.1:

$ pacman -Q | grep libreoffice
libreoffice-base 4.0.1-5
libreoffice-calc 4.0.1-5
libreoffice-common 4.0.1-5
libreoffice-de 4.0.1-1
libreoffice-draw 4.0.1-5
libreoffice-extension-ct2n 3.4.5-2
libreoffice-extension-diagram 3.4.5-2
libreoffice-extension-hunart 3.4.5-2
libreoffice-extension-nlpsolver 4.0.1-5
libreoffice-extension-numbertext 3.4.5-2
libreoffice-extension-oooblogger 3.4.5-2
libreoffice-extension-presentation-minimizer 4.0.1-5
libreoffice-extension-report-builder 4.0.1-5
libreoffice-extension-typo 3.4.5-2
libreoffice-extension-watch-window 3.4.5-2
libreoffice-extension-wiki-publisher 4.0.1-5
libreoffice-impress 4.0.1-5
libreoffice-kde4 4.0.1-5
libreoffice-math 4.0.1-5
libreoffice-sdk 4.0.1-5
libreoffice-writer 4.0.1-5

so I decided to uninstall all extensions in order to test if a old extension could be the reason:
# pacman -R $(pacman -Qq | grep libreoffice-extension)

result: error didn't occur any more on my side.


Comment by Andreas Radke (AndyRTR) - Saturday, 06 April 2013, 08:52 GMT
I can't confirm this and no ther users it seems. Going to close this soon as "works for me".
Comment by mattia (nTia89) - Saturday, 20 April 2013, 14:30 GMT
it happens with 4.0.2 too
Comment by mattia (nTia89) - Saturday, 20 April 2013, 14:40 GMT
tried to remove $HOME/.config/libreoffice

but no luck
Comment by mattia (nTia89) - Saturday, 11 May 2013, 09:14 GMT
with latest release 4.0.3.3 there is a little improvement:

now cells show me correctly the values of formulas, that is it doesn't show me "Err:520"
but if I try to expand it I get the same crash
Comment by mattia (nTia89) - Friday, 31 May 2013, 18:33 GMT
with latest official release 4.0.3.3
(which provides the latest numbertext version, too)

THE BUG WAS SOLVED

I'm not sure if it was definitively a numbertext problem or other...

Loading...