Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34487 - [nvidia-utils] nvidia-settings crash on startup

Attached to Project: Arch Linux
Opened by Felix Yan (felixonmars) - Wednesday, 27 March 2013, 04:56 GMT
Last edited by Andrea Scarpino (BaSh) - Friday, 29 March 2013, 13:13 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
$ nvidia-settings
nvidia-settings: ../sysdeps/posix/getaddrinfo.c:1732: rfc3484_sort: Assertion `s
rc->results[i].native == -1 || src->results[i].native == a1_native' failed.
Aborted (core dumped)

removing $HOME/.nvidia-settings-rc could help, but after a new one generated automatically, next run will fail again.

Additional info:
* package version(s)
nvidia-utils 313.26-1
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Friday, 29 March 2013, 13:13 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Thursday, 28 March 2013, 14:58 GMT
You're probably hitting this:
http://www.sourceware.org/bugzilla/show_bug.cgi?id=9954

Check your /etc/hosts file.
Comment by Felix Yan (felixonmars) - Friday, 29 March 2013, 12:17 GMT
@JGC
Whoops, seems right. Thanks a lot!

Loading...