Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34454 - [maxima] crashing to debugger when started with -s

Attached to Project: Arch Linux
Opened by Philip Abernethy (Chais) - Monday, 25 March 2013, 15:55 GMT
Last edited by Evangelos Foutras (foutrelis) - Friday, 12 April 2013, 18:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Maxima reliably crashes when started with -s , thus rendering GUIs like wxMaxima unable to connect to it. As a repo package it should be usable to it's full extent.

Additional info:
* extra/maxima 5.29.1-1
* extra/sbcl 1.1.4-1

Steps to reproduce:
- Install extra/maxima and be sure to use extra/sbcl
- Start maxima with $ maxima -s <any port> (tried with 1234 and 4090)
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Friday, 12 April 2013, 18:02 GMT
Reason for closing:  Not a bug
Additional comments about closing:  See Daniel's comment below.
Comment by Daniel Landau (dlandau) - Friday, 12 April 2013, 13:36 GMT
As per the man page:

"-s port, --server=port
Connect Maxima to server on port. Note that this does not create a Maxima server; Maxima is the client."

In other words, it's not supposed to work, unless you start the server elsewhere first. Some searching online as well as good old pacman -Ql found me this file: /usr/share/maxima/5.29.1/share/contrib/maxima-server.lisp

You can use it to start a server by:

$ maxima
(%i1) load ("/usr/share/maxima/5.29.1/share/contrib/maxima-server.lisp");
(%i2) :lisp (server-run);

Where I have left out all output. This will start a server on port 1042. The comments indicate that you should connect to it by telnet, which seems to give a normal maxima prompt. maxima -s 1042 atleast doesn't crash, but I don't really get what to do with it.

If you are mainly interested in wxMaxima, you should just install it. It works out of the box.

Loading...