Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34453 - [vlc] 2.0.5-4 isn't compiled with the --enable-fluidsynth flag

Attached to Project: Arch Linux
Opened by Erwan Thomas (Janotus) - Monday, 25 March 2013, 15:16 GMT
Last edited by Jan de Groot (JGC) - Thursday, 28 March 2013, 08:18 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hello

VLC 2.0.5-4 can't play midi files. The setting described in the wiki that should enable this feature doesn't exist (see https://wiki.archlinux.org/index.php/MIDI#VLC).

I suppose the package isn't compiled with the --enable-fluidsynth flag.

I haven't been able to check in the pkgbuild (git kept giving me error 500), but anyway see the output of this command on my system:

$ vlc --list | grep fluidsynth
VLC media player 2.0.5 Twoflower (revision 2.0.5-0-g1661b7d)
$

Therefore, this is a feature request, could you please include the --enable-fluidsynth flag in the pkgbuild ?

Thank you very much.
This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 28 March 2013, 08:18 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Fluidsynth support is covered by an optdepend. Support for fluidsynth is available in our packaged version of VLC.
Comment by Erwan Thomas (Janotus) - Tuesday, 26 March 2013, 15:08 GMT
I was able today to check the PKGBUILD, and it is confirmed, this vlc package isn't compiled with the --enable-fluidsynth option.
In addition, I noted that fluidsynth is present in the optional dependencies, which doesn't make sense to me given what precedes.
I added an entry in the wiki (same page as in the feature request) about that.
Comment by Philip Sequeira (qmega) - Wednesday, 27 March 2013, 04:55 GMT
VLC (2.0.5-4) plays midis fine for me with fluidsynth installed and a valid soundfont (tested with fluidr3). The FluidSynth audio codec shows up in the preferences on my machine, and after telling it where to find the sf2 it plays midis no problem. It can't seem to figure out how long they are, though; not sure if that's because of the lack of the compile option.

vlc --list does include fluidsynth on my machine. Perhaps you should check /usr/lib/vlc/plugins/codec/libfluidsynth_plugin.so (make sure it exists and run ldd on it and make sure all the libraries are satisfied).
Comment by Philip Sequeira (qmega) - Wednesday, 27 March 2013, 06:28 GMT
Rebuilding with --enable-fluidsynth doesn't fix the length detection issue.
Comment by Erwan Thomas (Janotus) - Wednesday, 27 March 2013, 07:26 GMT
Well this is embarrassing...
ldd /usr/lib/vlc/plugins/codec/libfluidsynth_plugin.so showed me that fluidsynth wasn't installed on my system. I don't why I automatically assumed it was present, but installing it obviously solved this 'issue'.

I'm sorry for the noise on the bug tracker and the wiki (modification is now undone), next time I'll know better and post in the forum.
Anyway, thank you qmega for your answer and for teaching me about that useful ldd command.

PS: I had already noticed this length detection issue on other systems, so I don't think it is related to Archlinux. Maybe reporting it upstream would be interesting, but given my newbieness I'm leaving it to my betters :).

Loading...