Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34448 - [imagemagick] Unable to convert svg to png

Attached to Project: Arch Linux
Opened by Sergio Tridente (TioDuke) - Monday, 25 March 2013, 00:05 GMT
Last edited by Eric Belanger (Snowman) - Tuesday, 26 March 2013, 18:37 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Whenever I issue the following command: convert image.svg image.png, the following messages are displayed and the process hangs (have to ctrl + C to regain control):

(process:14556): GLib-GObject-CRITICAL **: gtype.c:2720: You forgot to call g_type_init()

(process:14556): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed


It does not happen if I try the opposite, though: convert image.png image.svg


Additional info:
* package version(s)

imagemagick: 6.8.3.10-1
libpng: 1.5.14-1
librsvg: 2.36.4-1
glib2: 2.34.3-1
libxext: 1.3.1-1

* config and/or log files etc.


Steps to reproduce:

issue the following command: convert image.svg image.png
This task depends upon

Closed by  Eric Belanger (Snowman)
Tuesday, 26 March 2013, 18:37 GMT
Reason for closing:  Fixed
Additional comments about closing:  imagemagick-6.8.4.0-1
Comment by Sergio Tridente (TioDuke) - Monday, 25 March 2013, 00:08 GMT
Sorry forgot to add the name of the package in the title. Should be [imagemagick]
Comment by Eric Belanger (Snowman) - Monday, 25 March 2013, 01:55 GMT
I tried with a few images but couldn't replicate. Can you attach the image that's giving you problem?
Comment by Sergio Tridente (TioDuke) - Monday, 25 March 2013, 04:02 GMT
Attaching one of the files that are giving problems.
Comment by Evangelos Foutras (foutrelis) - Monday, 25 March 2013, 04:33 GMT
Can replicate on i686 but works fine on x86_64.
Comment by Evangelos Foutras (foutrelis) - Monday, 25 March 2013, 07:16 GMT
Gathered some more information and posted a bug report upstream:

http://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=23035
Comment by Sergio Tridente (TioDuke) - Monday, 25 March 2013, 10:40 GMT
Strange. I am on x86_64 and I am able to reproduce the problem. Maybe I am missing some dependencies?
Comment by Evangelos Foutras (foutrelis) - Monday, 25 March 2013, 11:33 GMT
The difference was that my x86_64 machine had Inkscape installed and, to my surprise, ImageMagick used that [1] instead of librsvg.

Bug is valid on both architectures after all.

[1] It's listed in /etc/ImageMagick-6/delegates.xml with decode="svg:decode"
Comment by Jan de Groot (JGC) - Monday, 25 March 2013, 22:03 GMT
g_type_init is deprecated since glib 2.35 and higher, as the type system is initialized automatically. Not calling it with previous versions is what we're seeing in this bug.

Loading...