Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34431 - [Gummiboot] waits on main screen (ignoring any timeouts) if no keyboard is plugged in

Attached to Project: Arch Linux
Opened by John Bergqvist (bergqvistjl) - Saturday, 23 March 2013, 15:30 GMT
Last edited by Tom Gundersen (tomegun) - Saturday, 23 March 2013, 23:23 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tom Gundersen (tomegun)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
If a PC using gummiboot is booted without a keyboard plugged in (i.e. such as on a server), instead of following the options specified in loader.conf, it brings up the gummiboot menu without a time-out (whether one is used or not). If a keyboard is then plugged in while at the menu, the menu can be navigated normally. I don't believe this is intended behaviour, as every other bootloader functions correctly without a keyboard being plugged in (and if it is intended, what's the point of popping up a menu that can only be navigated with the keyboard, as there isn't a keyboard plugged in anyway...)

Additional info:
* package version(s): 28-1
* config and/or log files etc.

loader.conf file:
timeout 1
default arch

arch.conf file:
title Arch Linux
linux /vmlinuz-linux
initrd /initramfs-linux.img
options root=/dev/sda2 rootfstype=ext4 ro add_efi_memmap quiet splash

Steps to reproduce:
1. Set-up gummiboot as normal to either use a timeout or boot straight into the OS. Confirm it works as normal with keyboard plugged in.
2. Shut-down system, unplug keyboard.
3. Boot system - watch as menu comes-up without a timeout.
This task depends upon

Closed by  Tom Gundersen (tomegun)
Saturday, 23 March 2013, 23:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  in [testing]
Comment by Tom Gundersen (tomegun) - Saturday, 23 March 2013, 17:32 GMT
informed upstream:

[18:31] <tomegun> kay__: is this known: https://bugs.archlinux.org/task/34431 ?
[18:33] <kay__> tomegun: no, seems that efi returns a pressed key, or something if no keyboard is there :)
[18:33] <kay__> tomegun: we might need to fix the logic, maybe it's a different return code ...
Comment by John Bergqvist (bergqvistjl) - Saturday, 23 March 2013, 17:33 GMT
It works fine when a keyboard is plugged in, but if no physical keyboard is plugged in, it ignores what's in loader.conf and just shows the menu, waiting for the user to choose a boot option. It doesn't even attempt to time out, as the time-out countdown message doesn't appear.
Comment by Tom Gundersen (tomegun) - Saturday, 23 March 2013, 18:50 GMT
Could any of you try out: http://cgit.freedesktop.org/gummiboot/commit/?id=9061fc1b739a2d9e67d3246cfa8d8e4d7a97ee0c ?

It has not been tested as neither Kay nor I have a computer with a detachable keyboard....
Comment by Tom Gundersen (tomegun) - Saturday, 23 March 2013, 18:50 GMT
Oops, by "any of you" I meant "you, John," :)
Comment by John Bergqvist (bergqvistjl) - Saturday, 23 March 2013, 18:57 GMT
Ignore this comment.
Comment by John Bergqvist (bergqvistjl) - Saturday, 23 March 2013, 19:55 GMT
OK, i've compiled it and the problem is gone, thanks :)
Comment by Tom Gundersen (tomegun) - Saturday, 23 March 2013, 22:18 GMT
@bergqvistjl: thanks for testing! Will be in the next release :-)
Comment by Tom Gundersen (tomegun) - Saturday, 23 March 2013, 23:23 GMT
New release in [testing].

Loading...