Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34401 - [gummiboot] Can't boot with kernel 3.8.3-2

Attached to Project: Arch Linux
Opened by Artem A Klevtsov (unikum) - Thursday, 21 March 2013, 21:28 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 17 June 2013, 10:28 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tom Gundersen (tomegun)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

I insttaled gummiboot and after last kernel update system can't boot: after boot logo appears black screen and nothing else.

Downgrade kernel to 3.8.2-1 provide success boot.

Additional info:
* package version(s)
core/linux 3.8.3-2
extra/gummiboot 28-1

ESP mounted as /boot.

With UEFI Shell v1 if I choose:
> fs0:
> \EFI\gummiboot\gummibootx64.efi
system boot success.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 17 June 2013, 10:28 GMT
Reason for closing:  Duplicate
Additional comments about closing:  33745
Comment by Artem A Klevtsov (unikum) - Friday, 22 March 2013, 14:05 GMT
Success boot with linux 3.8.4-1.
Comment by cfr (cfr42) - Saturday, 23 March 2013, 22:31 GMT
Is this the problem reported in https://bugs.archlinux.org/task/34358 and discussed in the linked forum thread? That issue seems to affect users using various combinations of EFI STUB / rEFInd / gummiboot, various 3.7.* and/or 3.8.* kernels, and various hardware / firmware. I realise that the reporter said 3.8.4 works but, as the forum thread shows, a different kernel sometimes works for some people but not others, though the next kernel may work for others but not some.
Comment by mjb (mjb) - Tuesday, 26 March 2013, 08:08 GMT
I think this is related to https://bugs.archlinux.org/task/33745
Comment by Ulf Winkelvos (uwinkelvos) - Tuesday, 26 March 2013, 21:55 GMT
It's the same issue here with gummiboot and kernel 3.8.2, linux-mainline (3.9rc{3,4}) from aur works though.
Comment by Ulf Winkelvos (uwinkelvos) - Tuesday, 26 March 2013, 22:02 GMT
Just tried 3.8.4 and it worked fine.
Comment by Ulf Winkelvos (uwinkelvos) - Thursday, 23 May 2013, 06:48 GMT
  • Field changed: Percent Complete (100% → 0%)
the 3.9 series started out ok, but with 3.9.3 its the same as before 3.8.4.

working:
linux-3.9-2-x86_64.pkg.tar.xz
linux-3.9.2-1-x86_64.pkg.tar.xz
not working:
linux-3.9.3-1-x86_64.pkg.tar.xz
Comment by Guillaume BROGI (guiniol) - Monday, 27 May 2013, 08:56 GMT
Same here with the 3.9.3 kernel (mainline or ck) and gummiboot 30-1.
I'm on a Thinkpad X230.

If I can help by testing or anything, just tell me.
Comment by Ulf Winkelvos (uwinkelvos) - Thursday, 06 June 2013, 00:46 GMT
not working:
linux-3.9.4-1-x86_64.pkg.tar.xz

3.10rc4 boots, works, but the screen is kind of "damaged". think thats an unrelated mode setting problem tough.
Comment by Ulf Winkelvos (uwinkelvos) - Saturday, 15 June 2013, 17:00 GMT
I am bisecting the other bug (the modesetiing problem with 3.10-rc2 +) and got some more information on this bug. The no boot bug diappears (again) somehwere in the 3.10-rc2. The problem seems to be in the kernel image and not in the initramfs: When i delete the initramfs img i get an error message that it can't be found. When i copy over an initramfs that was working for kernel 3.10-rc1 the system freezes like before.
Comment by Ulf Winkelvos (uwinkelvos) - Saturday, 15 June 2013, 22:23 GMT
This might sound stupid, but it is the kernel version string. I am not kidding! 3.9.0-rc3 does not work. If comment CONFIG_LOCALVERSION_AUTO in .config, the generated version string is "3.9.0-rc3-ARCH+" instead of "3.9.0-rc3-ARCH" and everything is fine. I am going to verify this with the stock kernel.

Loading...