Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34399 - [virtualbox] kernel oops on VM start

Attached to Project: Community Packages
Opened by Brandon (hashstat) - Thursday, 21 March 2013, 18:18 GMT
Last edited by Sébastien Luttringer (seblu) - Sunday, 19 May 2013, 23:47 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Ionut Biru (wonder)
Sébastien Luttringer (seblu)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

When starting VMs that worked under a previous version of VirtualBox, the kernel on the host machine Oops's sometime after the guest kernel starts. This is the case for both Linux and Windows VMs.

Additional info:
* virtualbox-4.2.10-1-x86_64 with virtualbox-host-modules-4.2.10-1-x86_64
* virtualbox-4.2.10-2-x86_64 with virtualbox-host-modules-4.2.10-2-x86_64
* linux-3.8.3-2-x86_64
* Also tried virtualbox-host-dkms-4.2.10-1
* Attached kernel Oops message

Steps to reproduce:
1. Update virtualbox and virtualbox-host-modules to 4.2.10-2
2. Update linux to 3.8.3-2
3. Start VirtualBox
4. Start VirtualBox Virtual Machine
5. Shortly after guest kernel starts, the host kernel will Oops, making the host unusable.

Steps to work around:
1. Downgrade virtualbox and virtualbox-host-modules to 4.2.8-1
2. Downgrade linux to 3.7.10-1
3. Holding packages at these versions resolves the issue.

I haven't yet been able to determine if this is due to an upstream bug or if it is Arch specific.
This task depends upon

Closed by  Sébastien Luttringer (seblu)
Sunday, 19 May 2013, 23:47 GMT
Reason for closing:  Upstream
Comment by Brandon (hashstat) - Thursday, 21 March 2013, 18:28 GMT
Found a couple more Oops messages in my kernel log. I can go back further and find more that are a bit different, if needed.
Comment by Brandon (hashstat) - Thursday, 21 March 2013, 19:17 GMT
I tried the following combination and get an Oops as well:
* linux-3.8.3-2
* virtualbox-4.2.8-1
* virtualbox-host-dkms-4.2.8-1

However, the following combination works:
* linux-3.7.10-1
* virtualbox-4.2.10-2
* virtualbox-host-dkms-4.2.10-2

This makes me think this is a bug in the upstream package related to a change in kernel version 3.8. Can anyone else confirm?

Regardless, I am stuck at kernel 3.7 until the bug is fixed as I depend on VirtualBox for many development tasks.
Comment by timemaster (timemaster) - Tuesday, 26 March 2013, 23:07 GMT
I am also affected by this issue running the lastest version available of virtualbox and the kernel. The Kernel oops is similar to the one Brandon has.
Fedora users running recent kernel seems to also be affected.
https://forums.virtualbox.org/viewtopic.php?f=7&t=54713
https://www.virtualbox.org/ticket/11610
Comment by Kent R. Spillner (sl4mmy) - Friday, 05 April 2013, 22:18 GMT
I encountered this issue today after upgrading to linux-3.8.5-1 and virtualbox-4.2.10-2. I had to downgrade back to linux-3.7.10-1 and virtualbox-4.2.8-1 in order to boot my virtual machines. Attached is the kernel Oops from /var/log/messages.log.

Here is a quick list of what I upgraded when I encountered the Oops vs what I downgraded in order to avoid the problem:
PACKAGE UPGRADE DOWNGRADE
linux 3.8.5-1 3.7.10-1
linux-headers 3.8.5-1 3.7.10-1
virtualbox 4.2.10-2 4.2.8-1
virtualbox-guest-iso 4.2.10-1 4.2.8-1
virtualbox-host-dkms 4.2.10-2 4.2.8-1
virtualbox-host-modules 4.2.10-3 4.2.8-1

I will add a similar comment to the upstream ticket as well. (Thanks for tracking that down, timemaster!)
Comment by Brandon (hashstat) - Monday, 15 April 2013, 16:22 GMT
This is still occurring with following package combination:
* linux 3.8.7-1
* virtualbox 4.2.12-1
* virtualbox-host-dkms 4.2.12-1
Comment by Kent R. Spillner (sl4mmy) - Friday, 17 May 2013, 06:59 GMT
  • Field changed: Percent Complete (100% → 0%)
Would like to update comments with a work-around for the benefit of other users who stumble upon this bug report.
Comment by Kent R. Spillner (sl4mmy) - Friday, 17 May 2013, 15:05 GMT
There exists a work-around for 32-bit guests: disable VT-x/AMD-V under Settings->System->Acceleration. I confirmed this works with linux-3.9.2-1 and virtualbox-4.2.12-3.

Unfortunately, 64-bit guests require VT-x/AMD-V be enabled so this work-around does not help.

Loading...