Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34329 - [slim] nm-applet will not start after logging out and back in again

Attached to Project: Arch Linux
Opened by Carl Duff (CarlD) - Friday, 15 March 2013, 19:50 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 23 April 2014, 17:02 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Where logging out and back in again using SLiM as the Display Manager, nm-applet will not start. This is due to a missing line in /etc/pam.d/slim that provides the appropriate permission to wake/restart nm-applet in SystemD.

The line to add to fix this problem is: session required pam_systemd.so

Additional info:
* package version: slim-1.3.5-1
* Related file: /etc/pam.d/slim

Steps to reproduce:

1. SLiM as Login Manager
2. nm-applet installed and called via .desktop file in /etc/xdg
3. log out and back into desktop again (issue found in Openbox)
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 23 April 2014, 17:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  slim 1.3.6-4
Comment by Daniel Wallace (gtmanfred) - Friday, 15 March 2013, 20:03 GMT
it should include pam_systemd.so

if you check /etc/pam.d/slim you will see

session include system-local-login

and in /etc/pam.d/system-local-login you will see

session include system-login

and in /etc/pam.d/system-login you will see

-session optional pam_systemd.so
Comment by Carl Duff (CarlD) - Friday, 15 March 2013, 21:04 GMT
As a side-note, I can fix this myself and submit the patched pkg.tar.xz file, if this helps.
Comment by Evangelos Foutras (foutrelis) - Saturday, 16 March 2013, 20:40 GMT
Works fine for me in Xfce. Also see Daniel's comment above about pam_systemd.so being included through system-local-login.
Comment by Carl Duff (CarlD) - Sunday, 17 March 2013, 00:04 GMT
Well, the file as it is does not work with Openbox. It only works after I manually inserted the pam_systemd.so line. Here is my source for the fix: https://bbs.archlinux.org/viewtopic.php?id=151863
Comment by Jan de Groot (JGC) - Wednesday, 20 March 2013, 00:09 GMT
Can you post your complete /etc/pam.d/slim file?
Comment by Carl Duff (CarlD) - Wednesday, 20 March 2013, 10:42 GMT
Certainly. Here is my amended /etc/pam.d/slim file:

#%PAM-1.0

auth include system-local-login
-auth optional pam_gnome_keyring.so
account include system-local-login
session include system-local-login
session required pam_systemd.so
-session optional pam_gnome_keyring.so auto_start
Comment by Alexander (ArchAlex) - Thursday, 16 May 2013, 16:16 GMT
I did everything described here and my /etc/pam.d/slim looks exactly like yours Carl but nm-applet still doesnt show after i relogin using slim
Comment by Pierre Neidhardt (Ambrevar) - Sunday, 28 July 2013, 16:58 GMT
Also SLiM has the "double logout freeze" issue as reported in the forums and in the Wiki: the solution is the add pam_systemd.so to SLiM's PAM as stated above.

Not sure if I should create another issue, since it is very related to this one and the solution is the same.
Comment by György Balló (City-busz) - Monday, 18 November 2013, 01:58 GMT
Here is the upstream bug report:
http://developer.berlios.de/bugs/?func=detailbug&bug_id=19102&group_id=2663

I put a warning into the wiki page about the incompatibility with systemd. Maybe it should be considered to drop SLiM from the official repositories.
Comment by Jan de Groot (JGC) - Monday, 21 April 2014, 11:35 GMT
Added the workaround from gentoo to 1.3.6-4 which is in testing (just cherry-pick it, no need for other pkgs from testing). This should fix the pam reuse problem that is causing this. Please try this package and confirm if it's fixed now.

Loading...