Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34307 - [speech-dispatcher] After update to 0.8 python2 bindings are missing

Attached to Project: Arch Linux
Opened by Peter Vágner (pvagner) - Thursday, 14 March 2013, 11:24 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 19 March 2013, 12:56 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

There is a package orca in extra which depends on speech-dispatcher . In earlier versions of speech-dispatcher this package also provided python2 bindings required by the orca package.
Latest update of this package only provides python 3 bindings.
I am not sure if it is a good idea to also install python2 bindings as a part of this package and then add a provide keyword or seperate python2-speechd package should be created for this.
This will allow package orca to request python2-speechd instead of speech-dispatcher.
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 19 March 2013, 12:56 GMT
Reason for closing:  Fixed
Additional comments about closing:  Added python2 bindings based on 0.7.1, using patches from 0.8 to resolve changes made in 0.8.
Comment by Jan de Groot (JGC) - Tuesday, 19 March 2013, 10:57 GMT
Upstream has removed python2 support from 0.8... the bindings require python 3.x now.

Loading...