FS#34250 - [libreoffice-calc] Fail to open ods from the file browser

Attached to Project: Arch Linux
Opened by Allen (allencch) - Monday, 11 March 2013, 00:46 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 12 March 2013, 14:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


After the upgrade of Libreoffice 4.0.1, double click ods file from the file browser will launch Libreoffice but does not open the file. This does not happen to odt and odp. Even run the Libreoffice, then open the file from the main page, the ods still cannot be open.
The ods can only be open after a new blank spreadsheat is open.

Additional info:
* libreoffice-calc 4.0.1-2

Steps to reproduce:
1) Make sure Libreoffice is not running
2) Use any file browser or even from the command-line use the xdg-open, open any ods file.
3) This will launch Libreoffice with splash screen, but exit immediately after splash screen.


1) Open Libreoffice (without open any document)
2) Open the ods file, this will see the statusbar show the loading, but no file open after this.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 12 March 2013, 14:50 GMT
Reason for closing:  Not a bug
Comment by Andreas Radke (AndyRTR) - Monday, 11 March 2013, 05:26 GMT
I've run a diff over libreoffice-calc.desktop files from 3.6.5 and 4.0.1 and they are identical with the same Mimetype.

I've created a new .ods file with LibO-calc 4.0.1 and saved it to /tmp/foo.ods. I could open it in thunar without any issue. Works for me(TM).

https://projects.archlinux.org/svntogit/packages.git/tree/trunk/libreoffice-calc.install?h=packages/libreoffice - the mimetype db update is included.

Maybe blame your new local pacman?
Comment by Allen (allencch) - Monday, 11 March 2013, 14:13 GMT
Even run "sudo update-desktop-database -q", then "libreoffice --calc /tmp/test.ods", this also does not work for me.
Comment by Allen (allencch) - Tuesday, 12 March 2013, 01:10 GMT
I am not sure whether this is a related bug or another bug. So I am not creating a new bug report first.
In the libreoffice calc, in any cell, if I enter "=", it will exit immediately. Even open an old ods file, press "F2" in any cell which contains the "=" (function), libreoffice will exit immediately.
The following is the error message during exit.

terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'
Comment by Allen (allencch) - Tuesday, 12 March 2013, 01:25 GMT
The problem is solved. The problem is caused by the libreoffice-extension-numbertext 3.4.5 from the AUR. After uninstall of this package, now calc works fine.
Comment by Alain (salan54) - Tuesday, 12 March 2013, 11:26 GMT
Thanks @Allen : I had the same problem and you solved it.