Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#34248 - [gummiboot] Installer can brick Samsung laptops!

Attached to Project: Arch Linux
Opened by Marius (65kid) - Sunday, 10 March 2013, 18:27 GMT
Last edited by Tom Gundersen (tomegun) - Wednesday, 13 March 2013, 15:38 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tom Gundersen (tomegun)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


The gummiboot installer can brick Samsung laptops because it replaces the EFI entry for the BIOS Setup. The BIOS is then unaccessible via the Samsung firmware.

I guess the package should be removed for now until we know more. Or at least remove "gummiboot install" from post_install.

see my post here for details:

This task depends upon

Closed by  Tom Gundersen (tomegun)
Wednesday, 13 March 2013, 15:38 GMT
Reason for closing:  None
Additional comments about closing:  we have done all we can. will revisit later.
Comment by Marius (65kid) - Sunday, 10 March 2013, 22:05 GMT
I know that this is obviously a firmware problem and not a bug in gummiboot (another user managed to cause a similiar problem with bcfg in the UEFI shell). I have no idea whether this can be worked around in gummiboot or the kernel itself (I guess Kay Sievers would be the right guy to talk to regarding this?). Even if Samsung fixes this, this will probably take weeks if not month. The question is just how this is dealt with within the package for now so people don't lock themselves out of the BIOS just by installing the package.

I do have the latest BIOS installed btw, it was just released 2 weeks ago.
Comment by Tom Gundersen (tomegun) - Sunday, 10 March 2013, 23:51 GMT
If any dev could move the new gummiboot from testing for me that would be great.
Comment by Tobias Powalowski (tpowa) - Monday, 11 March 2013, 07:57 GMT
Done. Removed from testing repositories.
Comment by Tom Gundersen (tomegun) - Wednesday, 13 March 2013, 04:32 GMT
The version in [extra] does not call the install script on install (but does update your EFI/bootloader on upgrade if you have installed gummiboot manually).

Out of curiosity, what exactly is the problem here? Gummiboot should not remove anything, just add an EFI entry and make itself the preferred bootloader. Is the problem that the firmware must be the preferred one? Would the problem be solved if gummiboot simply installed itself as the lowest, rather than highest, priority boot-loader?
Comment by Tom Gundersen (tomegun) - Wednesday, 13 March 2013, 04:34 GMT
Nevermind, all my questions were answered in the forum post (please include the relevant info in future bug reports rather than link to it :) ).
Comment by Marius (65kid) - Wednesday, 13 March 2013, 10:56 GMT
> please include the relevant info in future bug reports rather than link to it :)
yeah, I should have known better, sorry ;)

Since there is obviously nothing else that can be done in the package itself, I'm fine if you close this bug.