Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34236 - [xf86-video-ati] add glamor support

Attached to Project: Arch Linux
Opened by Alex (aion) - Saturday, 09 March 2013, 20:24 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 18 March 2013, 19:36 GMT
Task Type Feature Request
Category Packages: Testing
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

hardware acceleration doesn't work without it on Radeon SI
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 18 March 2013, 19:36 GMT
Reason for closing:  Implemented
Comment by Andreas Radke (AndyRTR) - Sunday, 10 March 2013, 10:25 GMT
Please test 1.7.0-3 in testing repo with glamor acceleration enabled.
Comment by Laurent Carlier (lordheavy) - Sunday, 10 March 2013, 11:36 GMT
and it should not work with xorg-server>1.12
Comment by Alex (aion) - Sunday, 10 March 2013, 11:47 GMT
xf86-video-ati with Xorg from testing works fine for me but glamor-egl package seems broken

everything works fine if I build glamor from this PKGBUILD: https://gist.github.com/5128263
Comment by Laurent Carlier (lordheavy) - Sunday, 10 March 2013, 11:54 GMT
hmm correct the proper config line for glamor is:
sh autogen.sh \
--prefix=/usr \
--with-xorg-conf-dir=/etc/X11/xorg.conf.d
Comment by Laurent Carlier (lordheavy) - Sunday, 10 March 2013, 11:55 GMT
no needs for a glamor.conf file in ld.so.conf!
Comment by Alex (aion) - Sunday, 10 March 2013, 12:09 GMT
Here my working PKGBUILD for glamor-egl
ld.so.conf hack seems necessary for workaround issue with xorg-server>1.12
Comment by Andreas Radke (AndyRTR) - Sunday, 10 March 2013, 13:58 GMT
Why should that ld.so.conf hack be required? All other Xorg libraries are loaded well from there.
Comment by Alex (aion) - Sunday, 10 March 2013, 14:18 GMT
Here my log without ld.so.conf hack.
Comment by Alex (aion) - Sunday, 10 March 2013, 14:51 GMT
If I understand correct hack just force loading glamoregl module before glx module.
Here my log with hack enabled.
Comment by Andreas Radke (AndyRTR) - Sunday, 10 March 2013, 18:27 GMT
Alex, can you please talk to the Xorg devs (Dave Airlie) on IRC or bring it to the Xorg-devel list if this is expected behavior and distro should workaround it with ld.so.conf.d or if it is a bug.
Comment by Alex (aion) - Sunday, 10 March 2013, 20:29 GMT Comment by Andreas Radke (AndyRTR) - Tuesday, 12 March 2013, 18:32 GMT
I'm implementing this ld.so.conf hack to get glamor working at all into glamor-egl 0.5.0-2.

But this should be fixed upstream in a proper way. I'll keep this open for now.

For now after Chris statement I see no need to also build the intel driver with glamor support enabled.
Comment by Laurent Carlier (lordheavy) - Tuesday, 12 March 2013, 18:40 GMT
seems wise. Glamor is only useful for radeonsi to get 2d acceleration.
Comment by Armin K. (Krejzi) - Tuesday, 12 March 2013, 19:42 GMT
Can you test with this patch? On my system libglamoregl.so appears to properly link with libglamor.so when patch is used.
Comment by Alex (aion) - Tuesday, 12 March 2013, 19:54 GMT
@ Armin, it helps, xorg starting ok and 3d working.

Upstream ticket: https://bugs.freedesktop.org/show_bug.cgi?id=62259
Comment by Armin K. (Krejzi) - Tuesday, 12 March 2013, 20:07 GMT Comment by Christos Kotsaris (TemplarGR) - Tuesday, 12 March 2013, 22:24 GMT
Question: According to the Radeon feature wiki, glamor should work in previous ati gpus too. I am on the r600g driver, and when i enable glamor as Accelmethod x doesn't show up (even with pkgrel 2 of glamor). Am i missing something?
Comment by Armin K. (Krejzi) - Monday, 18 March 2013, 13:34 GMT
My revised patches series are now upstream. Please add them to git-fixes.patch

You want

61879504f86c5cb326cc06a5873283234cfbbcd2
f2d7f1cf351bdc3a8a00fe564cd6a937db3b4e19
81aadb8ae204f58d77a948c8624f1e72659dcdf0

First one contains some fixes from AMD developer, second one makes libglamor.so versioned library installed in /usr/lib (no ld.so.conf entry needed) and third one disables static libraries properly. There are two more, but are not important unless you want to create a tarball using "make dist".
Comment by Andreas Radke (AndyRTR) - Monday, 18 March 2013, 18:28 GMT
Thanks. Applied all git commits. Can we now close this one as "implemented"?
Comment by Alex (aion) - Monday, 18 March 2013, 18:37 GMT
Works like charm for me. Thanks a lot Armin, Andreas, Laurent.

Loading...