Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34159 - [cmake] FindQt4 Does Not Work After Recent Qt5 Updates

Attached to Project: Arch Linux
Opened by Janne Rönkkö (jroo) - Tuesday, 05 March 2013, 16:45 GMT
Last edited by Andrea Scarpino (BaSh) - Thursday, 07 March 2013, 16:52 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
FindQt4 package fails because qmake is from Qt5.

See more details from upstream bug I submitted: http://public.kitware.com/Bug/view.php?id=13985

I submitted a patch fixing the issue to upstream (see the link above). It would be nice to include the patch in the Archlinux package until the issue is resolved in upstream.

Additional info:
* cmake-2.8.10-2

This task depends upon

Closed by  Andrea Scarpino (BaSh)
Thursday, 07 March 2013, 16:52 GMT
Reason for closing:  Fixed
Additional comments about closing:  cmake 2.8.10.2-5
kdelibs 4.10.1-2
Comment by Andrea Scarpino (BaSh) - Tuesday, 05 March 2013, 16:49 GMT
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Category (Packages: Extra → Upstream Bugs)
  • Task assigned to Andrea Scarpino (BaSh)
Let's see how cmake devs say about it.
Comment by Filip Brcic (brcha) - Wednesday, 06 March 2013, 17:38 GMT
Also /usr/share/apps/cmake/modules/FindQt4.cmake from kdelibs should be patched somehow (yet differently since the file is quite different, probably from the old cmake).

I'd suggest we just switch the list of qmakes it tests to first test for qmake-qt4, and then the rest. That is the easiest way, obviously not for global usage, but would fix things on Arch, at least until the upstream makes the possibility of qmake being from Qt5 into account.

After applying the above two patches to FindQt4 from both cmake and kdelibs I am now able to compile kde stuff from aur once again.
Comment by Filip Brcic (brcha) - Wednesday, 06 March 2013, 17:40 GMT
Damn... I said above since the attachments are above in the add comment form. Well, I hope you get the point :)

Loading...