Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34153 - [linux] 3.8.2-1 backlight bug after sleep

Attached to Project: Arch Linux
Opened by Enzzo (souenzzo) - Monday, 04 March 2013, 23:25 GMT
Last edited by Gaetan Bisson (vesath) - Tuesday, 02 April 2013, 02:50 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
When the notebook back from sleep, the screen brightness is zero.

"# echo 4882 > /sys/class/backlight/intel_backlight/brightness" solves the problem provisionally


Additional info:
* package version(s)
linux 3.8.2-1
* hardware
VAIO VPCEG13EB
Core i3 2nd gen / Intel HD 3000 / HM65 chipset

Steps to reproduce:
Arch linux "default" install + gnome 3.6 = everything ok
enable testing for test linux 3.8.2 + close notebook for sleep = problem.

This task depends upon

Closed by  Gaetan Bisson (vesath)
Tuesday, 02 April 2013, 02:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  Svenstaro reports this is fixed in 3.8.5.
Comment by Sven-Hendrik Haase (Svenstaro) - Friday, 08 March 2013, 13:54 GMT
Same deal here on a [testing] laptop. I need to use acpi_backlight=vendor in kernel line to get any backlight control at all. Is it the same for you? If so, the bug might be related to that.

lspci -vvv: http://pastie.org/6411466
Comment by Sven-Hendrik Haase (Svenstaro) - Friday, 08 March 2013, 14:04 GMT Comment by Enzzo (souenzzo) - Friday, 08 March 2013, 15:08 GMT
So, my backlight works on /sys/class/backlight/intel_backlight/ but on every kernel, every distro and every DE uses the /sys/class/backlight/acpi_video0/.
When I use acpi_backlight=vendor I get /sys/class/backlight/sony but the control still in intel_backlight.
I gave up looking for a solution to control/adjust the backlight, but it must always 100% like on legacy kernel, no?
Comment by james hall (detrimental) - Friday, 08 March 2013, 17:14 GMT
I have been having backlight issues with my intel hardware since the update from 3.6.11.

I confirm this issue, i always have testing enabled, did a reinstall before figuring out that testing repo was the issue.
Comment by Enzzo (souenzzo) - Saturday, 09 March 2013, 00:26 GMT
The sleep bug happens in ubuntu 13.04 with 3.8.0 too.
The intel_backlight/acpi_video0/sony bug happens with my notebook in all versions I tested (2.6/3.0/3.2/3.4/3.5/3.6/3.7/3.8).....
Comment by Enzzo (souenzzo) - Saturday, 09 March 2013, 00:27 GMT
With me the sleep bug occours just in 3.8.x
On 3.7/3.6... brightness is always at maximum
Comment by Enzzo (souenzzo) - Sunday, 17 March 2013, 22:17 GMT
Sill in 3.8.3
Comment by Giuseppe (shadowed87) - Tuesday, 19 March 2013, 08:54 GMT
Same as this one with a proposed patch from fedora

https://bugs.archlinux.org/task/34352
Comment by Szőllősi István (I-sty) - Wednesday, 20 March 2013, 12:57 GMT
Same error here. 3.8.3-2-ARCH
intel-dri 9.1-3
xf86-video-intel 2.21.4-1
linux 3.8.3-2
linux-api-headers 3.7.4-1
linux-firmware 20121118-1

Loading...