Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34143 - [texmacs] TeXmacs freezes on exit

Attached to Project: Arch Linux
Opened by Alain Kalker (ackalker) - Monday, 04 March 2013, 17:05 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 13 May 2015, 02:08 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

When I try to exit TeXmacs (1.0.7.16-2), it freezes (becomes unresponsive). The previous version (1.0.7.16-1) exits normally on a laptop which hasn't had the qt->qt4 update yet.

Running `texmacs` (latest version) from a terminal shows no errors, neither does `texmacs --debug` nor `texmacs --debug-events`. I can force it to exit by hitting C-c, so it's not completely dead.

Could this be related to the qt4 update?

Additional info:
* package version(s):
texmacs 1.0.7.16-1 (non-working)
texmacs 1.0.7.16-2 (non-working)
* config and/or log files etc.
Attaching diff of flattened dependency tree for package texmacs (with versions)
laptop$ pacman -Q (pactree -u texmacs) > texmacs-old.txt
desktop$ pacman -Q (pactree -u texmacs) > texmacs-new.txt
desktop$ diff -u texmacs-{old,new}.txt

Steps to reproduce:
- Run TeXmacs
- Try closing it using either the menu, keyboard shortcut or window close button.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 13 May 2015, 02:08 GMT
Reason for closing:  Fixed
Comment by Alain Kalker (ackalker) - Monday, 04 March 2013, 18:17 GMT
Cannot reproduce after full system update of the laptop.
I did discover that there are some missing optional dependencies, opening a new task for those.
Comment by Alain Kalker (ackalker) - Monday, 04 March 2013, 19:51 GMT
Attaching to texmacs.bin process with gdb and doing a backtrace reveals:
(gdb) bt
#0 0x00007fa44b35fdd1 in _nv012tls () from /usr/lib/libnvidia-tls.so.304.64
[...]
Alas, this appears to be a known Nvidia driver bug: http://projects.blender.org/tracker/index.php?func=detail&aid=29385&group_id=9&atid=231

How this bug reared its head after the qt4 upgrade still puzzles me, but you may want to close this bug, since it probably isn't relevant to TeXmacs.
Comment by Alain Kalker (ackalker) - Monday, 04 March 2013, 19:54 GMT
Ahh, most importantly, issuing (or adding to ${HOME}/.profile

export __GL_SINGLE_THREADED=1

resolves the issue: TeXmacs closes normally.
Comment by Doug Newgard (Scimmia) - Tuesday, 12 May 2015, 16:59 GMT
Status? That upstream report seems to indicate that current nvidia drivers fix this.
Comment by Alain Kalker (ackalker) - Tuesday, 12 May 2015, 20:19 GMT
I cannot reproduce this with nvidia 349.16-2, I'm assuming it has been fixed.
Please feel free to close this bug.

Loading...