Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34111 - cmake: FindKDE4 finds Qt5 by mistake

Attached to Project: Arch Linux
Opened by Iven Hsu (ivenvd) - Saturday, 02 March 2013, 15:03 GMT
Last edited by Andrea Scarpino (BaSh) - Saturday, 02 March 2013, 17:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
I'm maintaining the compiz-bar package in AUR, which uses FindKDE.cmake to detect KDE environment. When I run cmake, it outputs: http://pastebin.com/96AeMy1g

I think maybe it's caused by FindKDE4 finds Qt5 by mistake. Please fix it.

Additional info:
* testing/cmake 2.8.10.2-4
* extra/qt4 4.8.4-13

Steps to reproduce:
* Download compiz-bzr PKGBUILD from AUR
* Change KDEWINDOWDECORATOR="Off" to KDEWINDOWDECORATOR="On"
* makepkg
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Saturday, 02 March 2013, 17:16 GMT
Reason for closing:  Not a bug
Additional comments about closing:  use -DQT_QMAKE_EXECUTABLE=qmake-qt4
Comment by Gustavo Alvarez (sl1pkn07) - Saturday, 02 March 2013, 15:57 GMT Comment by Iven Hsu (ivenvd) - Saturday, 02 March 2013, 16:44 GMT
That's it. Thanks.

Loading...