Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34082 - [linux] 3.8.1-1r8168 doesn't work

Attached to Project: Arch Linux
Opened by phanisvara das (phani00) - Friday, 01 March 2013, 04:36 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 06 March 2013, 11:30 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

after upgrading to this kernel, wired network interface isn't detected. trying to load the module manually results in this:

[root@laptop phani]# modprobe r8168
modprobe: ERROR: could not insert 'r8168': Invalid argument

trying to install r8168-all from AUR, which mitigated the problem when this happened earlier, also doesn't work with this kernel.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 06 March 2013, 11:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  r8168 8.035.00-6; rebuilt, again. Weird that it broke on a minor kernel release.
Comment by . (Thralas) - Monday, 04 March 2013, 18:17 GMT
Do you have community-testing enabled? Obviously the package from community won't work (as it's built against 3.7).
Comment by Dave Reisner (falconindy) - Monday, 04 March 2013, 18:55 GMT
$ bsdtar xf /var/cache/pacman/pkg/r8168-8.035.00-5-x86_64.pkg.tar.xz
$ modinfo usr/lib/modules/extramodules-3.8-ARCH/r8168.ko.gz | grep vermagic
vermagic: 3.8.0-1-ARCH SMP preempt mod_unload modversions
Comment by phanisvara das (phani00) - Wednesday, 06 March 2013, 11:27 GMT
  • Field changed: Percent Complete (100% → 0%)
tried it again, with the package from community/testing (again), and it still gives the same error when trying to add the module via modprobe.

the package from AUR (r8168-all) has been fixed, after i notified the maintainer, who wasn't aware that the 3.8 kernels required a patch.

Loading...