Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34011 - cinnamon-screensaver should not conflict with gnome-screensaver

Attached to Project: Community Packages
Opened by K. Takacs (silent) - Monday, 25 February 2013, 06:12 GMT
Last edited by Alexandre Filgueira (faidoc) - Wednesday, 27 February 2013, 20:14 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description: cinnamon-screensaver 1.7.1-2 is required by cinnamon 1.7.1-1, but cinnamon-screensaver conflicts with gnome-screensaver, which is required by gnome-shell. As a result cinnamon and gnome-shell cannot be installed in parallel. Cinnamon-screensaver should not conflict with gnome-screensaver, instead they should only be autostarted in their corresponding DE's.

Additional info:
* package version(s)
cinnamon-screensaver 1.7.1-2
This task depends upon

Closed by  Alexandre Filgueira (faidoc)
Wednesday, 27 February 2013, 20:14 GMT
Reason for closing:  Fixed
Additional comments about closing:  Now cinnamon-screensaver 1.7.1-2 is only an optional dependency for cinnamon 1.7.1-3. Conflict between cinnamon-screensaver and gnome-screensaver is an upstream issue.
Comment by Gianluca Del Brusco (luxiter) - Monday, 25 February 2013, 14:04 GMT
i think low severity is bad, if u have installed cinnamon before this update you can't upgrade your system for conflict problem.
Medium severity should be more correct
Workaround is to disable community repo inside pacman.conf
Comment by Bruno Guerreiro (American_Jesus) - Monday, 25 February 2013, 14:29 GMT
There's no need to disable community repo, can use --ignore to skip a package: pacman -Su --ignore cinnamon

I'm having the same problem with cinnamon-screensaver, conflicts with gnome-screensaver but gnome-shell requires gnome-screensaver.
Must be something for they coexist
Comment by Jan de Groot (JGC) - Tuesday, 26 February 2013, 13:22 GMT
These packages have conflicting files. Besides that, adding provides is a no-go. Cinnamon-screensaver is a fork from GNOME 3.4's screensaver, using it with gnome-shell 3.6+ will result in broken features and weird bugs.

Loading...