Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#33992 - pacman -U http://... fails to fetch signature when file is in cache

Attached to Project: Pacman
Opened by Allan McRae (Allan) - Sunday, 24 February 2013, 03:00 GMT
Last edited by Anatol Pomozov (anatolik) - Saturday, 25 July 2020, 04:14 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To Anatol Pomozov (anatolik)
Architecture All
Severity Low
Priority Normal
Reported Version 4.0.3
Due in Version 6.0.0
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Using "pacman -U http://remote/file"; when the file is in the pacman cache will fail to download the .sig file if required. This should be a reasonably rare occurrence...

This is caused by the need to record the actual URL a file is coming from to add the ".sig" afterwards. One potential work around is to always download the file when using -U on a URL regardless of whether it is in the cache.
This task depends upon

Closed by  Anatol Pomozov (anatolik)
Saturday, 25 July 2020, 04:14 GMT
Reason for closing:  Implemented
Additional comments about closing:  master branch
Comment by Phillip Smith (fukawi2) - Friday, 19 April 2013, 01:01 GMT
A command line option to ignore the .sig would also be useful.

pacman --nosig -U http://example.com/foobar.pkg.tar.gz
Comment by Dario Pellegrini (DarioP) - Friday, 06 December 2019, 13:42 GMT
I encountered this bug too on Pacman v5.2.1 - libalpm v12.0.1
It seems fairly easy to fix if someone knows where to look.
Comment by Anatol Pomozov (anatolik) - Monday, 20 April 2020, 20:48 GMT
Just to double-check is it still an issue that need to be looked at? I might have some time in the future for it.
Comment by Anatol Pomozov (anatolik) - Monday, 27 April 2020, 02:14 GMT
A proposed fix has been published here https://github.com/anatol/pacman/tree/parallel-download
Comment by Eli Schwartz (eschwartz) - Tuesday, 07 July 2020, 12:44 GMT
  • Field changed: Due in Version (Undecided → 6.0.0)
  • Field changed: Percent Complete (0% → 100%)
Comment by Anatol Pomozov (anatolik) - Wednesday, 08 July 2020, 04:51 GMT
As Eli mentioned the fix got merged master branch.

Please install pacman from git master if you want to verify that it works as expected.

Loading...