Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33980 - [gummiboot-efi] build setup tool

Attached to Project: Arch Linux
Opened by Marius (65kid) - Saturday, 23 February 2013, 19:52 GMT
Last edited by Tobias Powalowski (tpowa) - Friday, 01 March 2013, 18:58 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The latest upstream gummiboot version contains a handy installer/updater tool [1] which does not seem be part of the package. Please build and add it to the package (maybe the update command could even be part of post_upgrade?).

As a btw, this makes me wonder why the x86_64 and i686 builds of gummiboot are not in separate packages, any specific reason for this?

[1] http://cgit.freedesktop.org/gummiboot/tree/src/setup/setup.c
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Friday, 01 March 2013, 18:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  v24-1 in testing
Comment by Tobias Powalowski (tpowa) - Sunday, 24 February 2013, 17:43 GMT
The reason for not having them seperated is because it depends on the UEFI of your vendor if it is i686 or x86_64.
Comment by Keshav Amburay (the.ridikulus.rat) - Tuesday, 26 February 2013, 08:04 GMT
Due to the limitation of devtools in not allowing mixed arch packages from same split PKGBUILD, I have created a separate PKGBUILD for gummiboot setup without touching the existing gummiboot-efi PKGBUILD. See the attached gummiboot-efi-setup src.tar.gz file.

EDIT: You can also add gummiboot-efi-setup as optdepends to gummiboot-efi pkg.

EDIT 2: One more thing to note is that gummiboot-setup requires /sys/firmware/efi/efivars support which is present only in kernels >=3.8, so it won't work with 3.7 and LTS kernels.
Comment by Tobias Powalowski (tpowa) - Tuesday, 26 February 2013, 11:50 GMT
I thought efivars is in the kernel since 2.6.32.
Comment by Keshav Amburay (the.ridikulus.rat) - Tuesday, 26 February 2013, 14:26 GMT
@tpowa: What you mean is the recently deprecated efi variables interface /sys/firmware/efi/vars which was designed for EFI 1.x spec actually and has some limitations (regarding secure boot etc.) which was fixed in an upgraded efivars interface /sys/firmware/efi/efivars which is actually the recommended interface now. Since the new interface is incompatible with the old one, the sysfs path for this one is different the old one. See http://blog.fpmurphy.com/2012/12/efivars-and-efivarfs.html for more info.

efibootmgr has not yet been updated upstream to support this new interface. This gummiboot-setup essentially duplicates efibootmgr functionality and the whole file copying/syncing work, but hardcoded for gummiboot alone.
Comment by Marius (65kid) - Tuesday, 26 February 2013, 15:40 GMT
@tpowa: thanks for the clarification, makes sense.

@the.ridikulus.rat: thanks, the PKGBUILD works fine and after some playing around, the install/remove/update procedures seem to work as expected on my Samsung 900x4d. On kernel 3.7 it will simply complain that efivars is not mounted, on kernel 3.8 efivars is mounted automatically (I guess it's mounted by systemd).

Loading...