Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33973 - [dosfstools] moveit to Core because EFI partition need it

Attached to Project: Arch Linux
Opened by Pablo Lezaeta (Jristz) - Friday, 22 February 2013, 20:16 GMT
Last edited by Tobias Powalowski (tpowa) - Friday, 31 May 2013, 16:49 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Actually dosfstool [extra] part of the deps on grub-efi-{i386,x86_64} [core]
is need to fsck into a EFI partition in a UEFI system

fallow the description on the wikia for core[1] that say:
* are needed to boot any kind of supported Arch system.
-Arch support UEFI no??
* can manage and check/repair supported filesystems.
- Manage Fat32 part of the specification of EFI no??
* are dependencies (but not necessarily makedepends) of the above.
- is dependecy on grub-efi in coreur grub complain about

please move it to Core because fit the caracteristiques for move it, and a fat32 EFI partition is difficul to tomanage if you not have a tool for it, or if you grub complain about missing tool

[1] https://wiki.archlinux.org/index.php/Official_Repositories

Steps to reproduce:
install a Bare core without any Extra dep and try to create and manipulate your EFI partition

PD: freetype2 in [Extra] deppend on grub-coomon [Core] this apply :
* are dependencies (but not necessarily makedepends) of the above.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Friday, 31 May 2013, 16:49 GMT
Reason for closing:  Implemented
Additional comments about closing:  3.0.17
Comment by Pablo Lezaeta (Jristz) - Friday, 08 March 2013, 03:39 GMT
and now whit systemd 198 that manage
efi partition I think that is more neede a tool for manage the fylesystem of these partitions

Loading...