Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33901 - libva-vdpau-driver

Attached to Project: Arch Linux
Opened by Carlos (cyberconan) - Sunday, 17 February 2013, 13:06 GMT
Last edited by Ionut Biru (wonder) - Thursday, 21 February 2013, 13:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description: The VLC last version can't play videos with VA API.

Additional info:
package version: 0.7.4-1

Steps to reproduce: Play videos with last VLC version.
If remove libva-vdpau-driver, VLC don't use VA API and video plays.
This task depends upon

Closed by  Ionut Biru (wonder)
Thursday, 21 February 2013, 13:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  ffmpeg 1.1.2-3
Comment by Ionut Biru (wonder) - Sunday, 17 February 2013, 16:18 GMT
paste the log when using vlc -vv moviefile
Comment by Carlos (cyberconan) - Sunday, 17 February 2013, 17:50 GMT
With libva-vdpau-driver installed:

[0x7fbdec000f48] avcodec decoder: Using VA API version 0.33 for hardware decoding.
[0x7fbdec000f48] avcodec decoder debug: Available decoder output format 61 (dxva2_vld)
[0x7fbdec000f48] avcodec decoder debug: Available decoder output format 53 (vaapi_vld)
[0x7fbdec000f48] avcodec decoder debug: Trying VA API
libva info: VA-API version 0.33.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/nvidia_drv_video.so
libva info: Found init function __vaDriverInit_0_33
libva info: va_openDriver() returns 0
[0x7fbdec000f48] avcodec decoder: Using VA API version 0.33 for hardware decoding.
ViolaciĆ³n de segmento (`core' generado)

Comment by Gustavo Alvarez (sl1pkn07) - Sunday, 17 February 2013, 18:03 GMT
ViolaciĆ³n de segmento (`core' generado) -> segment fault (core dumped)
Comment by Carlos (cyberconan) - Sunday, 17 February 2013, 18:08 GMT
I tested various files. Mpeg format works ok but avc (x264) cause bug. Similar problem with mplayer.

Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vdpau] 1920x1080 => 1920x1080 H.264 VDPAU acceleration
Assertion desc->flags & 16 failed at libavcodec/utils.c:508


MPlayer interrupted by signal 6 in module: decode video
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
won't help unless you provide this information when reporting a possible bug.
Comment by Gustavo Alvarez (sl1pkn07) - Sunday, 17 February 2013, 18:25 GMT
is a x264 10bits?

VDPAU can't handle x264 with 10bits [Hi10p] use XV instead
Comment by Carlos (cyberconan) - Sunday, 17 February 2013, 18:35 GMT
Yesterday I could play all my x264 files. Today with the updates of vlc, mplayer, ffmpeg, ... I can't :(
Comment by Carlos (cyberconan) - Sunday, 17 February 2013, 19:01 GMT
Downgrading this files:
ffmpeg-1:1.0.1-1-x86_64.pkg.tar.xz
mplayer-35421-2-x86_64.pkg.tar.xz
vlc-2.0.5-2-x86_64.pkg.tar.xz
x264-20121113-1-x86_64.pkg.tar.xz

...and all works fine again. Maybe the bug is in new /usr/lib/libx264.so.
Comment by Ionut Biru (wonder) - Sunday, 17 February 2013, 19:03 GMT
mplayer used to work fine in testing but i've got a new snapshot. is not related to this issue.
Comment by Carlos (cyberconan) - Sunday, 17 February 2013, 21:30 GMT Comment by Ionut Biru (wonder) - Sunday, 17 February 2013, 21:57 GMT
mplayer bug has been bisected as a bug in ffmpeg. expect new mplayer package tomorrow.

as for libva, i'm still debuging.
Comment by Gustavo Alvarez (sl1pkn07) - Sunday, 17 February 2013, 22:03 GMT
EDIT: nothing
Comment by Ionut Biru (wonder) - Monday, 18 February 2013, 17:40 GMT
for vlc, only vdpau provider is affected?
Comment by Carlos (cyberconan) - Monday, 18 February 2013, 18:24 GMT
I can't test VLC with libva-intel-driver, I haven't any computer with an intel graphic adapter.

Mplayer works fine again with ffhvpdau264. Thanks a lot.
Comment by Alexander Kaltsas (firewalker) - Tuesday, 19 February 2013, 16:27 GMT
On my laptop (i686) with intel gpu everything seems to be ok.

libva 1.1.0-2
libva-intel-driver 1.0.19-1
vlc 2.0.5-3
ffmpeg 1:1.1.2-2
x264 20130206-1

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

On my desktop (i686) with nVidia the problem is there.

03:00.0 VGA compatible controller: NVIDIA Corporation G98 [GeForce 8400 GS] (rev a1)


Comment by Ionut Biru (wonder) - Wednesday, 20 February 2013, 09:28 GMT
please report upstream to ffmpeg.
Comment by Alexander Kaltsas (firewalker) - Wednesday, 20 February 2013, 09:39 GMT Comment by Ionut Biru (wonder) - Wednesday, 20 February 2013, 09:40 GMT
is it possible. please test that patch.
Comment by Alexander Kaltsas (firewalker) - Wednesday, 20 February 2013, 09:42 GMT
I will do later this day.
Comment by jk (jk) - Wednesday, 20 February 2013, 10:38 GMT
VLC gpu accel not working after upgrade on libva-intel-driver, x86_64.
Comment by Alexander Kaltsas (firewalker) - Thursday, 21 February 2013, 11:58 GMT
I did an FFmpeg git-bisect and the results is the commit bellow.

c2dfb1e37cc72bf144545c4410a4621cbff5c4b1 is the first bad commit
commit c2dfb1e37cc72bf144545c4410a4621cbff5c4b1
Author: Michael Niedermayer <michaelni@gmx.at>
Date: Wed Dec 19 18:46:48 2012 +0100

h264: support frame size changes with multi threading

Based on code by Janne Grunau

Signed-off-by: Michael Niedermayer <michaelni@gmx.at>

:040000 040000 5b8facf405f660ec37f1047396c76f910b2cc9d6 67af2a0b8cc1243d1b4a356f1be5365f3edae27b M libavcodec


https://gitorious.org/ffmpeg/ffmpeg/commit/c2dfb1e37cc72bf144545c4410a4621cbff5c4b1/diffs
Comment by Ionut Biru (wonder) - Thursday, 21 February 2013, 12:08 GMT
nice job Alexander, have you contacted upstream about it?
Comment by Alexander Kaltsas (firewalker) - Thursday, 21 February 2013, 12:16 GMT
I tried to take advices form the official ffmpeg IRC channel but had no luck. I still can't confirm if this an FFmpeg or VLC or whatever issue. I opened a thread to the VLC forum also.

I don't know If I should fill a bug report for FFmpeg with something like "VLC can't use hardware decoding because of commit..."

I don't even know what the offending commit does. Maybe VLC team should change something in order to comply with the new FFmpeg.

Please enlighten me! :D :D :D
Comment by Ionut Biru (wonder) - Thursday, 21 February 2013, 12:28 GMT Comment by Alexander Kaltsas (firewalker) - Thursday, 21 February 2013, 12:44 GMT
Yep, the above patch fixes the problem for me too (nVidia card, libva-vdpau).
Comment by Carlos (cyberconan) - Thursday, 21 February 2013, 13:27 GMT
All works fine again in VLC. Thanks!!
Comment by Ionut Biru (wonder) - Thursday, 21 February 2013, 13:31 GMT
yuhu!

Loading...