Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#33887 - [linux] 3.7.6 - 3.8.x ehci_hcd module fails while boot, USB devices not recognized

Attached to Project: Arch Linux
Opened by oblivion (oblivion) - Saturday, 16 February 2013, 11:03 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 18 March 2013, 19:15 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 10
Private No



Linux MACHINENAME 3.7.8-1-ARCH #1 SMP PREEMPT Fri Feb 15 04:14:33 EET 2013 i686 GNU/Linux

USB storage and other devices (flash disk, camera, etc.) are not recognized due to ehci_hcd module fail.
This failure seems to be started started with Linux 3.7.7 update (I don't know if 3.7.6 has the same problem) and 3.7.8 has the same problem. I know that there is no problem with actual USB hub or devices on my machine, since I have no usb connection or speed problem with the Windows installation on the same machine and more importantly, reverting linux package back to 3.7.5 fixes this error. Currently (on 3.7.8), only manually reloading (modprobe -r ehci_hcd) ehci_hcd works.

I've attached the complete boot log (username and machine name are changed to dummy names.).

Additional info:
* package version(s)

Linux 3.7.7.
Linux 3.7.8.

* config and/or log files etc.

Steps to reproduce:

Plugin any USB device and it is not recognized untill reloading of ehci_hcd.
   boot.log (74.5 KiB)
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 18 March 2013, 19:15 GMT
Reason for closing:  Fixed
Comment by Siot (siot) - Saturday, 16 February 2013, 12:17 GMT
On Linux 3.7.6 runs ok. At least for me.
Comment by oblivion (oblivion) - Monday, 18 February 2013, 11:33 GMT
Update to 3.7.9-1 didn't fix this problem either, so I can add Linux 3.7.9-1 to the list.
Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 18 February 2013, 13:52 GMT
  • Field changed: Summary ([Kernel] ehci_hcd module fails while boot, USB devices not recognized → [linux] ehci_hcd module fails while boot, USB devices not recognized)
  • Field changed: Status (Unconfirmed → Waiting on Response)
  • Field changed: Category (Packages: Core → Upstream Bugs)
  • Task assigned to Thomas Bächler (brain0), Tobias Powalowski (tpowa)
Please report to upstream, there is nothing to do here. Thanks.
Comment by timon (nomit) - Wednesday, 20 February 2013, 17:15 GMT
The new Linux 3.7.9: bug still present.
Comment by Dave (DaveCode) - Thursday, 21 February 2013, 22:45 GMT
Bug confirmed under 3.7.9-1 with two mkinitcpio versions, 0.12.0-2 and 0.13.0-1. Please employ boot USB sticks in general kernel releng, thanks Arch. Fallback: running old kernel 3.6.11-1 on USB stick no problems.
Comment by Calvin Hobbes (calvin) - Saturday, 23 February 2013, 13:55 GMT
Confirmed under 3.7.9-1.
Comment by Mike Cloaked (mcloaked) - Sunday, 24 February 2013, 21:29 GMT
Is it possible that the report at is related to this?
Comment by Tobias Powalowski (tpowa) - Wednesday, 27 February 2013, 11:38 GMT
Status on 3.8?
Comment by oblivion (oblivion) - Wednesday, 27 February 2013, 15:39 GMT
@tpowa: I've installed linux 3.8.0-2 from the [testing] repo, and unfortunately, nothing's changed. USB hotplug devices are still not recognized.
Comment by Jens Adam (byte) - Wednesday, 27 February 2013, 23:09 GMT
I'm booting from a CF (or SD) card reader, connected to onboard USB 2.0 pins.
After upgrading to 3.8 kernel and rebooting the device wasn't recognized any longer, thus no card and no LUKS key to be found.

My solution: use 'ehci-pci' instead of 'ehci-hcd' to MODULES in mkinitcpio.conf (self-built, no autodetection)

Comment by Eric (eric2) - Tuesday, 05 March 2013, 16:12 GMT
In linux-mainline (3.9rc1) this issue is fixed :) maybe also in 3.8.2, I have not checked.
Comment by Natanael Copa (ncopa) - Wednesday, 13 March 2013, 07:26 GMT Comment by oblivion (oblivion) - Monday, 18 March 2013, 17:29 GMT
I see that as of linux 3.8.3-2, this issue seems to be fixed (on my machine).
Can anyone else confirm this?
Comment by Siot (siot) - Monday, 18 March 2013, 19:04 GMT

Runs ok on my arch pendrive with linux 3.8.3-2