Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33884 - [steam] Dwarfs!? depends on lib32-libgdiplus

Attached to Project: Community Packages
Opened by Dmitry Shapoval (unkier) - Saturday, 16 February 2013, 09:27 GMT
Last edited by Daniel Micay (thestinger) - Saturday, 16 February 2013, 09:37 GMT
Task Type Bug Report
Category Packages: Multilib
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Dwarfs!? depends on lib32-libgdiplus


Additional info:
* steam 1.0.0.25-4



Steps to reproduce:
* run Dwarfs!? without lib32-libgdiplus installed

Error log:

Mono: Assembly Ref addref System.Drawing[0xb1f2978] -> System[0xb1151e0]: 6

Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for System.Drawing.GDIPlus ---> System.DllNotFoundException: libgdiplus.so.0
at (wrapper managed-to-native) System.Drawing.GDIPlus:GdiplusStartup (ulong&,System.Drawing.GdiplusStartupInput&,System.Drawing.GdiplusStartupOutput&)
at System.Drawing.GDIPlus..cctor () [0x00000] in <filename unknown>:0
--- End of inner exception stack trace ---
at System.Drawing.Icon.GetInternalBitmap () [0x00000] in <filename unknown>:0
at System.Drawing.Icon.ToBitmap () [0x00000] in <filename unknown>:0
at (wrapper remoting-invoke-with-check) System.Drawing.Icon:ToBitmap ()
at OpenTK.Platform.X11.X11GLNative.set_Icon (System.Drawing.Icon value) [0x00000] in <filename unknown>:0
at OpenTK.NativeWindow.set_Icon (System.Drawing.Icon value) [0x00000] in <filename unknown>:0
at Microsoft.Xna.Framework.OpenTKGameWindow.Initialize () [0x00000] in <filename unknown>:0
at Microsoft.Xna.Framework.OpenTKGameWindow..ctor () [0x00000] in <filename unknown>:0
at Microsoft.Xna.Framework.OpenTKGamePlatform..ctor (Microsoft.Xna.Framework.Game game) [0x00000] in <filename unknown>:0
at Microsoft.Xna.Framework.GamePlatform.Create (Microsoft.Xna.Framework.Game game) [0x00000] in <filename unknown>:0
at Microsoft.Xna.Framework.Game..ctor () [0x00000] in <filename unknown>:0
at Dwarves.Game1..ctor (IntPtr p_wrap, IntPtr p_stats) [0x00000] in <filename unknown>:0
at DwarfsWindows.Program.Main (System.String[] args) [0x00000] in <filename unknown>:0
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: An exception was thrown by the type initializer for System.Drawing.GDIPlus ---> System.DllNotFoundException: libgdiplus.so.0
at (wrapper managed-to-native) System.Drawing.GDIPlus:GdiplusStartup (ulong&,System.Drawing.GdiplusStartupInput&,System.Drawing.GdiplusStartupOutput&)
at System.Drawing.GDIPlus..cctor () [0x00000] in <filename unknown>:0
--- End of inner exception stack trace ---
at System.Drawing.Icon.GetInternalBitmap () [0x00000] in <filename unknown>:0
at System.Drawing.Icon.ToBitmap () [0x00000] in <filename unknown>:0
at (wrapper remoting-invoke-with-check) System.Drawing.Icon:ToBitmap ()
at OpenTK.Platform.X11.X11GLNative.set_Icon (System.Drawing.Icon value) [0x00000] in <filename unknown>:0
at OpenTK.NativeWindow.set_Icon (System.Drawing.Icon value) [0x00000] in <filename unknown>:0
at Microsoft.Xna.Framework.OpenTKGameWindow.Initialize () [0x00000] in <filename unknown>:0
at Microsoft.Xna.Framework.OpenTKGameWindow..ctor () [0x00000] in <filename unknown>:0
at Microsoft.Xna.Framework.OpenTKGamePlatform..ctor (Microsoft.Xna.Framework.Game game) [0x00000] in <filename unknown>:0
at Microsoft.Xna.Framework.GamePlatform.Create (Microsoft.Xna.Framework.Game game) [0x00000] in <filename unknown>:0
at Microsoft.Xna.Framework.Game..ctor () [0x00000] in <filename unknown>:0
at Dwarves.Game1..ctor (IntPtr p_wrap, IntPtr p_stats) [0x00000] in <filename unknown>:0
at DwarfsWindows.Program.Main (System.String[] args) [0x00000] in <filename unknown>:0
This task depends upon

Closed by  Daniel Micay (thestinger)
Saturday, 16 February 2013, 09:37 GMT
Reason for closing:  Not a bug
Comment by Daniel Micay (thestinger) - Saturday, 16 February 2013, 09:36 GMT
The games are supposed to ship all of the libraries they need. This isn't a bug in either the Arch package or Steam - it's a bug the third party game dev has to tackle, so please report it to them.

Loading...