Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33840 - [nepomuk-core] should be rebuilt because of new ffmpeg

Attached to Project: Arch Linux
Opened by Bastian Beranek (totsilence) - Wednesday, 13 February 2013, 16:02 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 13 February 2013, 16:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: When starting the nepomukfileindexer by hand with nepomukservicestub, one will find with current testing ffmpeg (1:1.1.2-1) the following output:

nepomukindexer(8156)/nepomuk (strigi service): Could not create Extractor: "nepomukffmpegextractor"
nepomukindexer(8156)/nepomuk (strigi service): "Cannot load library /usr/lib/kde4/nepomukffmpegextractor.so: (libavutil.so.51: cannot open shared object file: No such file or directory)"

I assume this is because the ffmpeg extractor depends on libavutil.so.51 which was bumped to libavutil.so.52 with the new ffmpeg


Additional info:
* package version(s): nepomuk-core: 4.10.0-2, ffmpeg: 1:1.1.2-1

Steps to reproduce:

1. Quit nepomukfileindexer with:

qdbus org.kde.nepomuk.services.nepomukfileindexer /servicecontrol shutdown

2. Restart nepomukfileindexer with:

nepomukservicestub nepomukfileindexer

If there are any video files to be indexed the error message will be reported on the screen
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 13 February 2013, 16:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  nepomuk-core 4.10.0-3
Comment by Bastian Beranek (totsilence) - Wednesday, 13 February 2013, 16:06 GMT
Rebuilding the package myself, the error message indeed disappears.

Loading...