Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33828 - Kernel complains about dmsetup which is in the wrong place or should be symlinked or something...

Attached to Project: Arch Linux
Opened by AndrzejL (AndrzejL) - Tuesday, 12 February 2013, 17:21 GMT
Last edited by Thomas Bächler (brain0) - Tuesday, 12 February 2013, 19:04 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

:: Synchronising package databases...
core is up to date
extra is up to date
community 1920.4 KiB 49.8K/s 00:39 [#######################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...

Targets (16): cryptsetup-1.6.0-1 curl-7.29.0-2 device-mapper-2.02.98-3 inxi-1.8.37-1 iw-3.8-2 knemo-0.7.6-2
libnl-3.2.19-1 libpcap-1.3.0-2 linux-3.7.7-1 linux-headers-3.7.7-1 linux-lts-headers-3.0.63-1
lvm2-2.02.98-3 mdadm-3.2.6-3 net-snmp-5.7.2-2 networkmanager-0.9.6.4-2 wpa_supplicant-2.0-2

Total Installed Size: 158.25 MiB
Net Upgrade Size: -22.16 MiB

Proceed with installation? [Y/n] y
(16/16) checking package integrity [#######################################] 100%
(16/16) loading package files [#######################################] 100%
(16/16) checking for file conflicts [#######################################] 100%
(16/16) checking available disk space [#######################################] 100%
( 1/16) upgrading device-mapper [#######################################] 100%
( 2/16) upgrading cryptsetup [#######################################] 100%
( 3/16) upgrading curl [#######################################] 100%
( 4/16) upgrading inxi [#######################################] 100%
( 5/16) upgrading libnl [#######################################] 100%
( 6/16) upgrading iw [#######################################] 100%
( 7/16) upgrading knemo [#######################################] 100%
( 8/16) upgrading libpcap [#######################################] 100%
reboot
( 9/16) upgrading linux [#######################################] 100%
>>> Updating module dependencies. Please wait ...
>>> Generating initial ramdisk, using mkinitcpio. Please wait...
==> Building image from preset: 'default'
-> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 3.7.7-1-ARCH
-> Running build hook: [base]
-> Running build hook: [udev]
-> Running build hook: [lvm2]
==> ERROR: file not found: `/sbin/dmsetup'
-> Running build hook: [autodetect]
-> Running build hook: [block]
-> Running build hook: [filesystems]
-> Running build hook: [keyboard]
-> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip initcpio image: /boot/initramfs-linux.img
==> WARNING: errors were encountered during the build. The image may not be complete.
==> Building image from preset: 'fallback'
-> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 3.7.7-1-ARCH
-> Running build hook: [base]
-> Running build hook: [udev]
-> Running build hook: [lvm2]
==> ERROR: file not found: `/sbin/dmsetup'
-> Running build hook: [block]
-> Running build hook: [filesystems]
-> Running build hook: [keyboard]
-> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip initcpio image: /boot/initramfs-linux-fallback.img
==> WARNING: errors were encountered during the build. The image may not be complete.
error: command failed to execute correctly

and in the same time:

[root@andrzejl andrzejl]# updatedb
[root@andrzejl andrzejl]# locate dmsetup | grep bin
/usr/sbin/dmsetup
[root@andrzejl andrzejl]# which dmsetup
/usr/sbin/dmsetup
[root@andrzejl andrzejl]#

Regards.

Andrzej
This task depends upon

Closed by  Thomas Bächler (brain0)
Tuesday, 12 February 2013, 19:04 GMT
Reason for closing:  None
Additional comments about closing:  Added a note to the Arch Linux news.

We can't do anything about this now, until there's a proper workaround for this in pacman.
Comment by Dave Reisner (falconindy) - Tuesday, 12 February 2013, 18:08 GMT
The problem is that device-mapper is updated before lvm2 but not before linux. If you were to build your initramfs images again, you wouldn't see this error.

Not a whole lot to fix here without causing headaches elsewhere.
Comment by AndrzejL (AndrzejL) - Tuesday, 12 February 2013, 18:12 GMT
Understood. No problem.

Regards.

Andrzej

Loading...