Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33818 - [ffmpeg][xine-lib] xine-lib 1.2.2-6 breaks sound in Kaffeine

Attached to Project: Arch Linux
Opened by Adam Dagan (adam777) - Monday, 11 February 2013, 18:49 GMT
Last edited by Evangelos Foutras (foutrelis) - Saturday, 09 March 2013, 13:56 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Eric Belanger (Snowman)
Ionut Biru (wonder)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

xine-lib 1.2.2-6 breaks sound decoding in Kaffeine when watching DVB-T.
Sample recording from Kaffeine attached.
   123.m2t (1.01 MiB)
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Saturday, 09 March 2013, 13:56 GMT
Reason for closing:  Fixed
Additional comments about closing:  xine-lib 1.2.2-7
Comment by Eric Belanger (Snowman) - Monday, 11 February 2013, 20:11 GMT
My guess is that it's an issue with the ffmpeg in testing.
Comment by Adam Dagan (adam777) - Tuesday, 12 February 2013, 15:07 GMT
Thank, Eric.
Did some testing:
- Downgrading xine-lib to 1.2.2-5 isn't helpful - I get a blank screen if trying to open the sample in Kaffeine.
- Downgrading ffmpeg to the version in Extra isn't helpful - same result.
- Downgrading both isn't helpful as well, still blank screen. which is odd, as thing did work a couple days back.
Comment by Eric Belanger (Snowman) - Tuesday, 12 February 2013, 17:40 GMT
If you want to try domwngrading, you'll also need to downgrade x264.
Comment by Adam Dagan (adam777) - Tuesday, 12 February 2013, 18:52 GMT
It worked.
The following downgrades leads to a working setup:
xine-lib (1.2.2-6 => 1.2.2-5)
ffmpeg (1:1.1.2-1 => 1:1.0.1-1)
x264 (20130206-1 => 20121113-1)
Comment by Ionut Biru (wonder) - Thursday, 14 February 2013, 05:36 GMT
i'm not sure what is going on.
Comment by Ionut Biru (wonder) - Saturday, 16 February 2013, 22:32 GMT Comment by Adam Dagan (adam777) - Saturday, 09 March 2013, 09:50 GMT
Hi Ionut,
I've been away for a few weeks and 2 things has happened during this time.
- I decided to reinstall my system, not using [testing] this time, since I really do not have the knowledge to do even simple things such as applying a patch as you suggested.
- The package in question (xine-lib 1.2.2-6) has since moved to Extra, so now the problem is not restricted to [testing].
Luckily I had a copy of the 4 older versions, so I could "fix" the problem by downgrading.
Perhaps you could try applying the patch on your side and link to a patched package, or point me to a simple step-by-step tutorial on how to apply a patch to source and create an Arch package.
Adam.
Comment by Evangelos Foutras (foutrelis) - Saturday, 09 March 2013, 10:43 GMT
I've tested that patch and it doesn't fix the sound (it still sounds like white noise).
Comment by Evangelos Foutras (foutrelis) - Saturday, 09 March 2013, 11:10 GMT
Please test xine-lib 1.2.2-7 from [extra]; it includes an upstream patch [1] that fixes the sound for me.

[1] http://projects.vdr-developer.org/git/xine-lib.git/commit/?id=679582503c8ba2f91a82e44c4a2938550306fd07
Comment by Adam Dagan (adam777) - Saturday, 09 March 2013, 13:36 GMT
I can confirm, 1.2.2-7 solves the issue.
Thanks all.

Loading...