Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33813 - [kdesdk-kate] has a plugin version comparison issue

Attached to Project: Arch Linux
Opened by Andrew D. (andrewd18) - Monday, 11 February 2013, 15:34 GMT
Last edited by Andrea Scarpino (BaSh) - Monday, 11 February 2013, 17:55 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Not all the plugins available for Kate 4.10 are visible in the selection box. See https://bugs.kde.org/show_bug.cgi?id=314530

"In KatePartPluginManager::setupPluginList(), it uses "([X-KDE-Version] >= 4.0) and ([X-KDE-Version] <= 4.10" constraint when querying the plugins. It's doing float comparison, so 4.3 > 4.10."

This bug has already been fixed upstream. Any chance we could get an Arch pkgbuild revbump & patch to tide users over until the March 5 release?

Additional info:
* kdesdk-kate 4.10.0-1
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Monday, 11 February 2013, 17:55 GMT
Reason for closing:  Fixed
Additional comments about closing:  kdesdk-kate 4.10.0-2

Loading...