Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33812 - [ffmpeg] circular dependency with xine-lib

Attached to Project: Arch Linux
Opened by Lone_Wolf (Lone_Wolf) - Monday, 11 February 2013, 13:48 GMT
Last edited by Ionut Biru (wonder) - Saturday, 16 February 2013, 22:25 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

ffmpeg 1:1.1.2-1 [testing]

after updating today i noticed xine-lib was added to my packages.
I checked the dependency tree and found a new circular dependency :


ffmpeg requires frei0r-plugins
frei0r-plugins requires openvc
openvc requires xine-lib
xine-lib requires ffmpeg

since frei0r-plugins is a new dependency of ffmpeg, adding a bug for ffmpeg seemed the best way to bring this under attention.
This task depends upon

Closed by  Ionut Biru (wonder)
Saturday, 16 February 2013, 22:25 GMT
Reason for closing:  Fixed
Comment by Matthias Dienstbier (fs4000) - Tuesday, 12 February 2013, 14:56 GMT
It seems ffmpeg can optionally depend on frei0r-plugins. That solves this issue and the huge amount of additional dependencies for people who don't need frei0r-plugins.

Loading...