Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33811 - [curl] segfault with 7.29.0

Attached to Project: Arch Linux
Opened by Olivier Brunel (jjacky) - Monday, 11 February 2013, 10:36 GMT
Last edited by Dave Reisner (falconindy) - Tuesday, 12 February 2013, 13:57 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Dave Reisner (falconindy)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:

A bug in curl 7.29.0 can lead to a segfault when closing an unused multi handle. This has been fixed upstream already:
https://github.com/bagder/curl/commit/da3fc1ee91de656a30f3a12de394bcba55119872

Repackaging with a patch could be nice, since a few applications can now crash w/ the new curl. I believe  FS#33779  is an example of this; using xmlrpc-c often leads to a crash as well, etc.
This task depends upon

Closed by  Dave Reisner (falconindy)
Tuesday, 12 February 2013, 13:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  core/curl-7.29.0-2
Comment by Dave Reisner (falconindy) - Monday, 11 February 2013, 10:59 GMT
Yeah I had my eye on this patch. Wasn't sure how easy it was to reproduce in the wild.
Comment by Dave Reisner (falconindy) - Monday, 11 February 2013, 11:15 GMT
7.29.0-2 is in testing with this fix.
Comment by Doug Newgard (Scimmia) - Monday, 11 February 2013, 12:38 GMT
Thanks for the quick fix, Enlightenment was having a number of problems with this, too.

Loading...