Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33809 - [gimp-gap] Master Videoencoder plugin crashes

Attached to Project: Community Packages
Opened by Jay (jaydug) - Monday, 11 February 2013, 09:08 GMT
Last edited by Alexander F. Rødseth (xyproto) - Thursday, 14 February 2013, 20:01 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Alexander F. Rødseth (xyproto)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

Using the Master Videoencoder plug-in included in gimp-gap does not work. This is one of the main functions of the plugin, as it renders the results. Various options were used all resulted in the plug-in crashing, including both Frames and Layers mode and all of the encoding modes.

Additional info:
* Gimp version: 2.8.4-1
* Gimp-Gap version: 2.6.0-3

Steps to reproduce:

-Open Gimp
-Create a multilayer image
-Click "Video" pull down
-Click "Master Videoencoder..."
-Fill out parameters or take defaults
-Click "OK"

Results:

Plugin crashes: /usr/lib/gimp/2.0/plug-ins/gap_vid_common_encoder: fatal error: Segmentation fault
This task depends upon

Closed by  Alexander F. Rødseth (xyproto)
Thursday, 14 February 2013, 20:01 GMT
Reason for closing:  Upstream
Additional comments about closing:  Doesn't compile out of the box, segfaults, no webpage, no recent release, git version doesn't compile.
Comment by Alexander F. Rødseth (xyproto) - Monday, 11 February 2013, 18:19 GMT
Thanks for reporting. I recently adopted the gimp-gap package. I will look at the issue.
Comment by Alexander F. Rødseth (xyproto) - Tuesday, 12 February 2013, 11:32 GMT
Confirmed, I also get:

/usr/lib/gimp/2.0/plug-ins/gap_vid_common_encoder: fatal error: Segmentation fault

Upon investigating, I see that Gimp is at 2.8, but GAP is at 2.6. I'm also unable to find any webpage for GAP 2.6 for Linux.

There were some problems compiling gimp-gap that I resolved, but the result is the same. I tried compiling without ffmpeg that comes with it.

I will look into the GNOME/gimp-gap sources on github.
Comment by Jay (jaydug) - Tuesday, 12 February 2013, 20:07 GMT
Ok, found some more information. I'm assuming this is the same issue. Looks like you're already on top of getting the github code, which apparently has a fix:

https://bugzilla.gnome.org/show_bug.cgi?id=641078
Comment by Alexander F. Rødseth (xyproto) - Wednesday, 13 February 2013, 18:29 GMT
Thanks. I'll see if I find a way to make the git-version compile.
Comment by Jay (jaydug) - Wednesday, 13 February 2013, 19:04 GMT
Update, I actually managed to get the git version to compile and it does work. There's still a weird error that pops up, but ultimately, the video gets created. There were a couple of things I needed to do. I had to edit the autogen.sh file. There are some lines that check for automake, but they only look for versions up to 1.11 and arch linux is on 1.13. Just need to add a check for the latest version. Also, for some reason -lm doesn't get added to GLIB_LIBS, so linking fails (this happens with a lot of applications for me, not sure if it's something wrong with my system). Had to manually edit the MakeFile in the main directory and in "gap" to include -lm in the list.
Comment by Alexander F. Rødseth (xyproto) - Thursday, 14 February 2013, 12:32 GMT
Yeah, -lm has to be linked as one of the last libraries for it to build. Nice work.

Would you mind uploading your working package as gimp-gap-git on AUR?

Since gimp-gap doesn't have a working release, doesn't have a webpage and doesn't compile "out of the box", it feels more like a badly maintained development project than a project that's ready to be an official package. I'm considering dropping gimp-gap from [community], for now.

If a working release for Gimp 2.8 appears, gimp-gap could be moved back. And if gimp-gap-git on AUR would grow somewhat popular (10 votes), then that package could be moved to [community] instead.

What do you think?
Comment by Jay (jaydug) - Thursday, 14 February 2013, 19:14 GMT
I've never made a package before and don't have any idea how to do it :-/ I agree it probably belongs in AUR given its current state. No one is maintaining it. Too bad, it's the only program of it's kind right now.
Comment by Alexander F. Rødseth (xyproto) - Thursday, 14 February 2013, 20:00 GMT
Ok, removed gimp-gap from [community] and added gimp-gap-git to AUR.

If you're interested, here is the page for the package in AUR: https://aur.archlinux.org/packages/gimp-gap-git/
Here is the PKGBUILD (that currently doesn't compile): https://aur.archlinux.org/packages/gi/gimp-gap-git/PKGBUILD

Any suggestions for how to fix it (according to what you did) are warmly welcome, either as a comment to that package, or if you adopt it and modify the PKGBUILD.

It's fairly straightforward to use AUR, and there is plenty of info on the Arch wiki, if you should be interested. Feel free to email me as well, if you should be stuck somehow.

Thanks.

Closing this bug.

Loading...