Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#33779 - VMPlayer and VMWorkstation crashed (SIGABRT) after update curl to curl-7.29.0-1-x86_64.pkg.tar.xz

Attached to Project: Arch Linux
Opened by Ivan Rychtar (urys) - Saturday, 09 February 2013, 12:45 GMT
Last edited by Dave Reisner (falconindy) - Monday, 11 February 2013, 11:08 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No


VMPlayer and VMWare crashed (SIGABRT) after update curl to curl-7.29.0-1-x86_64.pkg.tar.xz

Additional info:
$ vmplayer
Logging to /tmp/vmware-urys/vmware-modconfig-12114.log
HostinfoReadDistroFile: Cannot work with empty file.
HostinfoOSData: Error: no distro file found
filename: /lib/modules/3.7.6-1-ARCH/misc/vmmon.ko
supported: external
license: GPL v2
description: VMware Virtual Machine Monitor.
author: VMware, Inc.
vermagic: 3.7.6-1-ARCH SMP preempt mod_unload modversions
Neúspěšně ukončen (SIGABRT) (core dumped [obraz paměti uložen])

when I downgrade to curl-7.28.1-1-x86_64.pkg.tar.xz VMPlayer and VMWare works good

uname -a
3.7.6-1-ARCH #1 SMP PREEMPT Mon Feb 4 09:15:13 CET 2013 x86_64 GNU/Linux

Steps to reproduce:
update curl to curl-7.29.0-1-x86_64.pkg.tar.xz and run VMPlayer or VMWorkstation
This task depends upon

Closed by  Dave Reisner (falconindy)
Monday, 11 February 2013, 11:08 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#33811 
Comment by Grzegorz Antoniak (antekone) - Saturday, 09 February 2013, 17:03 GMT
Same here, though I'm getting SIGSEGV.

Here is a gdb log of "gdb --args ./vmware":

(gdb) bt
#0 0x00007fffec2a54a0 in curl_multi_cleanup () from /usr/lib/
#1 0x00007fffe8116e7c in ?? () from /usr/lib/vmware/lib/
#2 0x00007ffff63ed090 in g_hash_table_foreach () from /usr/lib/
#3 0x00007fffe81163ab in CdsXfer_Destroy () from /usr/lib/vmware/lib/
#4 0x00007fffe8110606 in Cds_FreeClient () from /usr/lib/vmware/lib/
#5 0x00007fffe71147be in cui::ComponentMgrCDS::~ComponentMgrCDS() () from /usr/lib/vmware/lib/
#6 0x00007fffe76e8b89 in lui::ToolsMgr::ToolsMgr(lui::DlgMgr*) () from /usr/lib/vmware/lib/
#7 0x00007fffe5e13677 in ui::App::Init(int, char**) () from /usr/lib/vmware/lib/
#8 0x00007fffe5e14496 in ui::App::App(int, char**) () from /usr/lib/vmware/lib/
#9 0x00007fffe5e4a853 in main () from /usr/lib/vmware/lib/
#10 0x0000555555571836 in main ()

Based on libcurl's git, it seems they've changed curl_multi_cleanup(), resulting in ABI breakage.

Hackish workaround, without downgrading curl, is to force vmware startup script to use bundled inside /usr/vmware/lib/ This involves applying this patch to /usr/bin/vmware (the patch is attached to this post).

Update: please note that this is only a temporary workaround. When libcurl will be updated with a version that contains the fix mentioned by jjacky below, please remove this patch by restoring the original startup script (you have a backup, right?).
Comment by Ivan Rychtar (urys) - Saturday, 09 February 2013, 19:52 GMT
thanks for workaround, so here is same for vmplayer
Comment by Arthur Huillet (ahuillet) - Sunday, 10 February 2013, 14:51 GMT
I confirm that the vmplayer patch is working. Thanks guys!
Comment by Valentino Pistis (zappa) - Sunday, 10 February 2013, 17:28 GMT
Thanx! after many hours...the solution for vmplayer!!!
Comment by Sebi Kul (sebikul) - Sunday, 10 February 2013, 22:57 GMT
The Gambas3 packages are also affected. Crash only occurs at the end of the program.
Comment by Ismail (ism) - Monday, 11 February 2013, 09:04 GMT
Thanks. It works! :)
Comment by Fredrik Wahlström (FredZake) - Monday, 11 February 2013, 09:18 GMT
Thanks for the patch it does indeed work for me as well (workstation 8)!
I did however first try to "run" the patch before I opened it and realised that I needed edit /usr/bin/vmware manually =), could be nice to add that to the description.

Comment by Olivier Brunel (jjacky) - Monday, 11 February 2013, 10:38 GMT
I think this is due to a bug in curl 7.29.0, so you should patch curl instead of other apps. Upstream fix is here:

(I've also opened  FS#33811  to suggest repackaging curl)