Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33777 - [system-config-printer] conflict files version with python2.7

Attached to Project: Arch Linux
Opened by patrick (potomac) - Friday, 08 February 2013, 23:51 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Saturday, 09 February 2013, 01:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I notice a conflict version file when I try to update the system-config-printer

it get these error messages :

Erreur : la validation de la transaction a échoué (conflit de fichiers)
system-config-printer : /usr/lib/python2.7/site-packages/cupshelpers/__init__.pyc est déjà présent dans le système de fichiers
system-config-printer : /usr/lib/python2.7/site-packages/cupshelpers/config.pyc est déjà présent dans le système de fichiers
system-config-printer : /usr/lib/python2.7/site-packages/cupshelpers/cupshelpers.pyc est déjà présent dans le système de fichiers
system-config-printer : /usr/lib/python2.7/site-packages/cupshelpers/openprinting.pyc est déjà présent dans le système de fichiers
system-config-printer : /usr/lib/python2.7/site-packages/cupshelpers/ppds.pyc est déjà présent dans le système de fichiers
system-config-printer : /usr/lib/python2.7/site-packages/cupshelpers/xmldriverprefs.pyc est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n'a été mis à jour.



Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce: do a "pacman -Syu" command
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Saturday, 09 February 2013, 01:11 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#33769 
Comment by Kevin (anonymous_user) - Saturday, 09 February 2013, 00:03 GMT Comment by patrick (potomac) - Saturday, 09 February 2013, 00:21 GMT
the solution given by Andrea Scarpino is not acceptable ( the "--force" option ), because there is no news about this in the "news" section of the archlinux website,

the option "--force" should never be used until someone posts a news in the archlinux official website,

a better option is probably to rebuild the package in order to avoid the conflict files ( by testing the presence of python2.7 ? )
Comment by Gerardo Exequiel Pozzi (djgera) - Saturday, 09 February 2013, 01:10 GMT
rm /usr/lib/python2.7/site-packages/cupshelpers/*.pyc
then install

Loading...