Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#33770 - [lftp] not downloading/uploading files

Attached to Project: Arch Linux
Opened by Fraterius (Fraterius) - Friday, 08 February 2013, 16:55 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 12 February 2013, 19:24 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No



Instead of downloading files it just continuesly waits with no action and no progress (0% all the time) never mind whether I use put, get or mirror always the same result, I need to send interrupt signal. If I downgrade to version 4.4.2-1 everything works just fine.

Additional info:
tried to debug, I've set debug to 3 and 5 but the log seems to be useless
I didn't tried ftp or http traffic only sftp

Steps to reproduce:

Connect to remote sftp server using key with password and try to download/upload any file or mirror folder. Everything works with previous version of lftp.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 12 February 2013, 19:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  built 4.4.3-2 with the changed source.
Comment by Jens Adam (byte) - Friday, 08 February 2013, 18:18 GMT
lftp with sftp://user@host is working normally for me (key auth with ssh-agent)
Comment by Fraterius (Fraterius) - Friday, 08 February 2013, 19:27 GMT
For me it's not. From what I see it must be some upstream bug cause maintainer didn't change a thing. I'm also not using standard port, problem is that I login with no problem, I can ls and so on, but can't put/get anything. I'd say that problem is my config which only has one alias or other os config, but on previous version everything works great.

I'll try to debug it and put here some logs.
Comment by mbone (mbone) - Saturday, 09 February 2013, 07:58 GMT
I'm having the same problem. Initially I thought it was an ssl issue, but even on plaintext sites the problem exists. After downgrading the package to 4.4.2 and it works fine again.

With debug set to 5, you should see some activity that looks like this:
lftp> get mirc635.txt
---> SIZE mirc635.txt
<--- 213 5988
---> MDTM mirc635.txt
<--- 213 20081017195236
---> PASV
<--- 227 =(194,97,2,67,223,134).
---- Connecting data socket to ( port 57222
---> RETR mirc635.txt

When you try it on 4.4.3, with debug set to 5, you see nothing after you issue the get command, and eventually the server kicks you for sitting idle.
Comment by Xyne (Xyne) - Saturday, 09 February 2013, 09:46 GMT
+1 for unencrypted transfer not working. I have downgraded for now.

If this can't be fixed before the next upstream release then the last working version should be pushed back to the repo. As it is, the package is broken (which imo warrants a "high"severity rating).
Comment by Andreas Radke (AndyRTR) - Saturday, 09 February 2013, 09:52 GMT
Please report it upstream!
Comment by Dieter Hsu (d1t2hsu) - Monday, 11 February 2013, 00:44 GMT
I fix this by recompiling source(x86_64) from upstream using ABS PKGBUILD with different md5.
Comment by Christopher Eby (kreed) - Tuesday, 12 February 2013, 05:22 GMT
I was also able to fix the issue by compiling the PKGBUILD myself. I also had to update the MD5 to b877c1f82b2d4dc503f40dcce4978ff4
Comment by Fraterius (Fraterius) - Tuesday, 12 February 2013, 13:32 GMT
Ok so there's a huge propability that developer of lftp made some changes to 4.4.3 version, or arch developer downloaded wrong file. Andreas can you push the changes to 4.4.3-2?