Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33721 - [refind-efi] Kernel Hangs When Loaded with Refind Defaults

Attached to Project: Arch Linux
Opened by Mark E. Lee (bluerider) - Tuesday, 05 February 2013, 01:02 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 13 February 2013, 15:57 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When loading the arch linux kernel via defaults, refind hangs at starting vmlinuz. Strangely, when I load the kernels from the options menu (pressing +), the kernel loads normally.

Additional info:
linux 3.7.5-1
refind-efi 0.6.7-1

### Refind_linux.conf ###
"Boot with Defaults" "root=UUID=698a56e0-6683-49ea-94ab-0facd8153c9f rootflags=,relatime,data=ordered rootfstype=ext4 ro initrd=\EFI\arch\initramfs-linux.img add_efi_memmap"
"Boot to Terminal" "root=UUID=698a56e0-6683-49ea-94ab-0facd8153c9f rootflags=,relatime,data=ordered rootfstype=ext4 ro initrd=\EFI\arch\initramfs-linux.img add_efi_memmap 3"

Steps to reproduce:
Set up refind to automatically load a kernel and have it automatically boot the kernel.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 13 February 2013, 15:57 GMT
Reason for closing:  Fixed
Comment by Mark E. Lee (bluerider) - Wednesday, 06 February 2013, 15:55 GMT
Downgrading to refind-efi 0.6.6-1 fixes the issue. There is something wrong in refind-efi 0.6.7-1.
Comment by Mark E. Lee (bluerider) - Saturday, 09 February 2013, 17:08 GMT
Upgrading to linux 3.7.6-1 and using refind-efi 0.6.7-1 also fixed the issue.
Comment by Mark E. Lee (bluerider) - Saturday, 09 February 2013, 17:09 GMT
I am requesting closure of the bug, since a kernel upgrade has fixed the problem.
Comment by Mark E. Lee (bluerider) - Saturday, 09 February 2013, 18:35 GMT
Oh wait, the problem has returned...
Comment by Mark E. Lee (bluerider) - Sunday, 10 February 2013, 15:40 GMT
I recompiled linux (using the ABS) and the problem has gone away (confirmed with several reboots over two days).
Comment by Mark E. Lee (bluerider) - Tuesday, 12 February 2013, 19:04 GMT
A kernel upgrade to Linux 3.7.7-1 has introduced a new error. Systemd enters into recovery mode due to being unable to mount /boot/efi. Note, my linux-bfs installation does not have this problem. I would recompile the kernel for my system using ABS (but the ABS build scripts haven't updated to the new kernel yet). Is there any work being done on this particular error?

Loading...