Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33669 - [oxygen-gtk2] Upgrade to 1.3.2-1 is buggy

Attached to Project: Arch Linux
Opened by David Rosenstrauch (darose) - Friday, 01 February 2013, 14:55 GMT
Last edited by Andrea Scarpino (BaSh) - Thursday, 07 February 2013, 15:03 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

I'm not quite sure exactly what the problem is (are?), but the latest upgrade to v1.3.2-1 seems to be causing several problems:

1) Oxygen-gtk2 is no longer using my color scheme in several places (XFCE panel, pinentry dialog, etc.)
2) Leafpad fails with a segfault.

Downgrading back to 1.3.1-1 makes the problem go away.

Any idea what's broken?
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Thursday, 07 February 2013, 15:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  oxygen-gtk2 1.3.2-2
Comment by Andrea Scarpino (BaSh) - Saturday, 02 February 2013, 17:34 GMT
Please report this upstream.
Comment by David Rosenstrauch (darose) - Wednesday, 06 February 2013, 19:47 GMT
FYI - please note as per https://bugs.kde.org/show_bug.cgi?id=314545#c1 that the author suggests that Arch downgrade back to v1.3.1 until he releases a fix.
Comment by Antonio (kokoko3k) - Thursday, 07 February 2013, 13:33 GMT
Yep, upstream said to report to distro packagers and roll back :)
Comment by Andrea Scarpino (BaSh) - Thursday, 07 February 2013, 13:42 GMT
Patch applied to 1.3.2.-2, let me (and upstream) know if this is fixed
Comment by Antonio (kokoko3k) - Thursday, 07 February 2013, 14:36 GMT
My issue was that ardour segfaults at start, and it is fixed with 1.3.2-2, thanks.
Comment by David Rosenstrauch (darose) - Thursday, 07 February 2013, 15:01 GMT
Looks fixed. Colors display correctly in latest version, and leafpad doesn't segfault.

Loading...