Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#33646 - pulseaudio requires running bluetooth.service

Attached to Project: Arch Linux
Opened by Peter Weber (hoschi) - Wednesday, 30 January 2013, 21:10 GMT
Last edited by Dave Reisner (falconindy) - Thursday, 31 January 2013, 13:42 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


It looks for me that pulseaudio requires a running bluetooth.service or it will print error messages:

pulseaudio[253]: [pulseaudio] bluetooth-util.c: org.bluez.Manager.ListAdapters() failed: org.freedesktop.systemd1.LoadFailed: Unit dbus-org.bluez.service failed to load: No such file or directory.

Tomegun said [1] here that the wording of the error message can be improved.
This error message disappears after enabling "bluetooth.service"! So at least pulseaudio requires "bluetooth.service" or just thinks it needs "bluetooth.service". Currently bluetooth is an optional dependency of pulseaudio. Maybe "bluetooth.service" should be set as dependency of pulseaudio? Or pulseaudio should be configured differntly, so it doesn't require bluetooth or the error message shouldn't be printed in this case (I think this was the intention of Tomegun).

I recognized this only because I faced the same error message on my desktop (which doesn't include bluetooth-hardware) and the message disappeared after I enabled "bluetooth.service". Which is a workaround but not proper solution. On my laptop, which has bluetooth capable hardware, this message was never printed because I've enabled bluetooth.service during installation.
This task depends upon

Closed by  Dave Reisner (falconindy)
Thursday, 31 January 2013, 13:42 GMT
Reason for closing:  Not a bug
Comment by Daniel Wallace (gtmanfred) - Wednesday, 30 January 2013, 21:14 GMT
it isn't required for pulseaudio to work, there is a reason bluez is in the opt-depends, still not a bug
Comment by Peter Weber (hoschi) - Thursday, 31 January 2013, 10:48 GMT
It just shouldn't print the line.
Comment by Dave Reisner (falconindy) - Thursday, 31 January 2013, 13:42 GMT
Then mask dbus-org.bluez.service if you don't want to see it. There's no bug here.