Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33636 - [libvirt] Could not access KVM kernel module: Permission denied failed to initialize KVM: Permission

Attached to Project: Community Packages
Opened by Arnaud Sautaux (cretingame) - Wednesday, 30 January 2013, 10:57 GMT
Last edited by Sergej Pupykin (sergej) - Wednesday, 30 January 2013, 15:05 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

I use virt-manager to start a virtual machine. I do a update (pacman -Syu). And I have this message every time I launch a virtual machine :

Could not access KVM kernel module: Permission denied failed to initialize KVM: Permission

I do a downgrade to libvirt-1.0.1-2-x86_64 and it works fine.

Additional info:
* libvirt-1.0.1-4-x86_64
* a forum page with the same problem and solution : http://forums.gentoo.org/viewtopic-t-925976-start-0.html
Citation from this page:
"I ended up downgrading to app-emulation/libvirt-0.9.11.3 from app-emulation/libvirt-0.9.12.
Not the best solution, but I needed my VMs more than I needed a headache at the moment. :)"


Steps to reproduce:
pacman -S libvirt
pacman -Syu
pacman -U libvirt-1.0.1-2-x86_64.pkg.tar.xz // downgrade to fix
This task depends upon

Closed by  Sergej Pupykin (sergej)
Wednesday, 30 January 2013, 15:05 GMT
Reason for closing:  Not a bug
Comment by Sergej Pupykin (sergej) - Wednesday, 30 January 2013, 13:02 GMT
Current libvirt version works from nobody:nobody by default, but it can be changed in config. May it be the problem?
See /etc/libvirt/qemu.conf
user=
group=
Comment by Sergej Pupykin (sergej) - Wednesday, 30 January 2013, 15:05 GMT
I checked it
user="root"
group="root"
works. But it would be better to use something like virtuser:kvm.

Loading...