Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33606 - [evdev] No input driver specified, ignoring this device

Attached to Project: Arch Linux
Opened by Martin Zajíc (zajca) - Monday, 28 January 2013, 09:59 GMT
Last edited by Jan de Groot (JGC) - Monday, 28 January 2013, 11:37 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
On start any start of X. Input devices are not working (Keyboard, mouse, poweroff switch on pc case).


Additional info:
Kernel 3.7.3-1
evdev 2.7.3-2

Xorg.0.log:
(II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0)
No input driver specified, ignoring this device.
This device may have been added with another device file.

Link to forum:
https://bbs.archlinux.org/viewtopic.php?id=156788
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 28 January 2013, 11:37 GMT
Reason for closing:  Not a bug
Comment by Martin Zajíc (zajca) - Monday, 28 January 2013, 10:46 GMT
Solved in kernel Kernel 3.7.4 sorry I was too hasty with bug.
Comment by Jan de Groot (JGC) - Monday, 28 January 2013, 11:37 GMT
/dev/input/mouse* are supposed to be ignored, only /dev/input/event* devices should be used. In your case you probably didn't have the evdev kernel module loaded, resulting in not having /dev/input/event* devices.

Loading...