Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33592 - systemd-analyze missing dependency python2-gobject

Attached to Project: Arch Linux
Opened by Chris Down (chrisdown) - Sunday, 27 January 2013, 10:50 GMT
Last edited by Eric Belanger (Snowman) - Sunday, 27 January 2013, 12:28 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: systemd-analyze requires python2-gobject to work, otherwise it raises an ImportError. This is not currently a dependency on the core/systemd package.

Steps to reproduce:

* Uninstall python2-gobject if installed
* Install systemd
* Try to run systemd-analyze

----

$ systemd-analyze
Traceback (most recent call last):
File "/usr/bin/systemd-analyze", line 23, in <module>
from gi.repository import Gio
ImportError: No module named gi.repository
$ sudo pacman -S python2-gobject

[...]

$ systemd-analyze
Startup finished in 4565ms (kernel) + 4669ms (userspace) = 9235ms
This task depends upon

Closed by  Eric Belanger (Snowman)
Sunday, 27 January 2013, 12:28 GMT
Reason for closing:  Not a bug
Additional comments about closing:  it's an optdepends
Comment by Chris Down (chrisdown) - Sunday, 27 January 2013, 10:54 GMT
Note: this is with systemd 197-4. Apologies for forgetting to enclose the package name in brackets in the issue title.

Loading...